MEC-E5004 - Fluid Power Systems
[bookmark: _GoBack]Simscape Fluids exercise
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Simscape is an environment for modeling and simulating multidomain physical systems within Matlab/Simulink. More than 10 physical domains, including mechanical, electrical and hydraulic (Simscape Fluids) are covered. In this assignment both the Simscape Fluids and Simulink domains are mostly utilized. 

With Simscape physical component models can be generated based on physical connections by using physical units for both parameters and variables. All unit conversions are handled automatically.Cylinder piston’s position can be controlled in open and closed loop by using directional proportional control valve. System includes
• Differential cylinder with inertia load (mass)
• Directional proportional control valve
• Pressure compensated pump (constant pressure)
• Control system for position control
• (Presure relief valve)
Hydraulic actuator force needed only for mass acceleration and deceleration since there is no  mechanical friction in this system.
In the assignment the cylinder piston is moved 
a) into – direction and b) into + direction
both by using a) open loop and b) closed loop control.

     The hydraulic system to be modeled
Open Matlab.
Open the Simscape model template for your Simscape Fluids models. 
For opening give Matlab command
ssc_new
This will open the 
· Model template with
· Solver Configuration block to specify the solver parameters for your model 
· Simulink-PS Converter and PS-Simulink Converter blocks for data transfer between Simscape and Simulink domains
· Foundation library
[image: ]
You can enter Matlab command SimscapeFluids_lib for Simscape Fluids block library. 
[image: ] Library: SimscapeFluids_lib
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Library: SimscapeFluids_lib > Hydraulics (Isothermal)

[image: cid:image013.png@01D454CB.47CF9DF0]
Model canvas

Open loop control – assignment phase 1

Find Hydraulics (Isothermal) > Hydraulic Utilities library, open it (double clicking) and use the mouse to drag a Hydraulic Fluid block to your new model canvas. 
With this block you can determine the physical properties of the hydraulic fluid. 
· density, 
· viscosity, and 
· bulk modulus.

1. Open Hydraulic Fluid block by double clicking it. 
2. Change the Hydraulic Fluid from Skydrol LD-4 to ISO VG 32 (ESSO UNIVIS N 32). 
3. Keep the other fluid parameters the same.
Skydrol is fire-resistant aviation hydraulic fluid: http://skydrol-ld4.com/technical_bulletin_skydrol_4.pdf.

  Connect the Solver Configuration (f(x)=0) and Hydraulic Fluid blocks. 
· With left mouse button draw a wire between blocks’ terminals. 
· OR
· Click on the first block with the left button of your mouse
· Press Ctrl button of your keyboard
· Click on the second block
· Connection (Wire) will be formed automatically.
         [image: ]
Solver Configuration Hydraulic Fluid 
The Solver Configuration block defines solver settings for your model. 
Attention! You can rotate blocks by using Crtl-R keyboard command.

In your canvas window click Library Browser button to open Simulink Library Browser.

[image: ]
From the Simulink Library Browser’s Simscape > Foundation library 
[image: ]


Pick the next two blocks and drag them to the model canvas. 

Block                                                         From Sublibrary

	Hydraulic Constant Pressure Source
	Foundation Library > Hydraulic > Hydraulic Sources

	Hydraulic Reference
	Foundation Library > Hydraulic > Hydraulic Elements

	
[image: cid:image004.png@01D454CB.47CF9DF0]
	Hydraulic Constant Pressure Source and
Hydraulic Reference


	
	


The Hydraulic Reference block represents a connection to atmospheric pressure.

Connect these elements on the canvas. To make the branch use mouse’s right button. 

	[image: ]
	Simscape Fluids
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	Hydraulics (Isothermal)
[image: cid:image012.png@01D454CB.47CF9DF0]



From the Simscape > Fluids library, pick and drag two blocks to the model canvas. 
	Block
	                From Sublibrary

	Double-Acting
Hydraulic Cylinder
(Simple) 
	               Hydraulics (Isothermal) > Hydraulic Cylinders

	4-Way Directional Valve
	               Hydraulics (Isothermal) > Valves > Directional Valves

	
	


  The block connections represent the physical connections between the actual components. The cylinder connects to the valve, which connects to the pump, which in turn connects to the fluid reservoir. 
  From the Simscape > Foundation > Mechanical > Translational library, add a Mechanical Translational Reference block
[image: cid:image011.png@01D454CB.47CF9DF0]
 and connect it as shown in the figure below.
 [image: ]
· Connect the 4-way Directional Valve to the Double-Acting Hydraulic Cylinder as follows. 
[image: ]
· From the Simscape > Foundation > Mechanical > Translational Elements library, add a Mass block and connect it as shown in the figure below.
[image: ]
· From the Simscape > Foundation > Mechanical > Mechanical Sensors library bring an Ideal Translational Motion Sensor block and connect it as in the figure below (both C and R terminals).
[image: ]
· Connect the Ideal Translational Motion Sensor block to PS-Simulink Converter and Scope as follows. 
[image: ]Velocity
Position
Velocity
Position

· From the Hydraulics (Isothermal) > Valves > Valve Actuators library bring a Valve Actuator block and connect it to Simulink-PS Converter and 4-Way Directional Valve as in the figure below.
[image: ]Valve Actuator Block

· Connect the 4-Way Directional Valve to Hydraulic Constant Pressure Source block and to the Hydraulic Reference block as in the figure below.
[image: ]
Pressure sensors
[image: ]for measuring cylinder chamber pressures.
· From the Simscape > Foundation library bring Hydraulic > Hydraulic Sensors > Hydraulic Pressure Sensor block. Make a copy of it (Ctrl-C and Ctrl-V) and connect those 
· between Hydraulic Cylinder’s A interface and Hydraulic Reference (B interface)
· between Hydraulic Cylinder’s B interface and Hydraulic Reference (B interface)

[image: ]
· Connect both of the Hydraulic Pressure Sensor(s) to Scope(s) by using a PS-Simulink Converter as follows. You can use the existing converter and make a copy of it.   
[image: ]
[image: ]Signal inputs
From the Simulink Library Browser > Sources bring 
Step block  clone it (Ctrl-C and Ctrl-V) to get 4 blocks together.
Constant block
[image: ]
From the Simulink Library Browser > Math Operations bring 
Add block
 [image: ]
Connect the blocks with Simulink-PS Converter block as follows. 
[image: ] Constant (named U_0) block represents the valve’s zero point parameter. At first set the Constant value to 0. 
Adjust that parameter later to keep cylinder still during zero input signal. 
The Step blocks are used for step input commands for the proportional control valve. These parameters values will also be set later.


Pipes

From the Library: Simscape > Fluids > Hydraulics (Isothermal) > Pipelines bring Hydraulic Pipeline block. 

[image: ]

Make a copy of it and connect those two to Hydraulic Cylinder’s A and B interfaces and corresponding A and B interfaces of 4-Way Directional Valve as in the figure below.
Attention! Remember that you can rotate blocks by using Crtl-R keyboard command.
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System Parameters 
Double click blocks to open
Set system parameters as follows.
Step blocks for timing of the valve commands (usable voltage area: -10 V …  0  … +10 V).
	[image: ]U [V]

	


[image: ] Set Time and Final valuet [s]

Step block 1 parameters
[image: ] Set Time and Final value
Step block 2 parameters
[image: ] Set Time and Final value
Step block 3 parameters
[image: ] Set Time and Final value
Step block 4 parameters
Constant (named U_0) block represents the valve’s zero point parameter. Run the simulation (after setting other parameters) and adjust that parameter to keep cylinder still during zero input. 
Valve Actuator
[image: ]
· maximum Valve stroke 0.005 m (5 mm)
· by applying 10 V input the Actuator reaches full 5 mm stroke
· therefore the Actuator gain is 0.005/10 [m or in theory m/V]
· the value for the Time constant can be 0.002 s (2 ms)
Hydraulic Constant Pressure Source (ideal constant pressure pump)
[image: ]
· ideal pump with constant pressure of 120 bar (120105 [Pa] in Matlab: 120e5 [Pa])
4-Way Directional Valve (proportional valve)
For a narrow (mainly turbulent flow) orifice the flow rate isIf we know 
· nominal flow rate (qv), 
· nominal pressure drop (p), 
· fluid density () and 
· flow coefficient (Cq) 
the corresponding flow area can be calculated as follows










For leakage of a certain proportional control valve
qv	0.45 l/min  0.45/60000 m3/s
p	50 bar  50105 Pa
	844.4 kg/m3 (from Hydraulic fluid block for ISO VG 32 hydraulic fluid at 60C)
Cq	0.7 	(for turbulent region)
Open the 4-Way Directional Valve block dialog box by double clicking.
[image: ]
Set the Leakage area parameter as follows.  
Leakage area parameter (0.45 l/min @ p= 50 bar over each control edge), use Copy+Paste.
0.45/60000/(0.7*sqrt(2*50e5/844.4))
In Model Parametrization page 
Maximum opening parameter 0.005 m
Maximum opening area parameter, use Copy+Paste 
Actual flow area (40 l/min @ 35 bar) + Leakage area 		+                    
40/60000/(0.7*sqrt(2*35e5/844.4))+0.45/60000/(0.7*sqrt(2*50e5/844.4)) 
	[image: ]
	Simscape’s way of modeling orifice area



h                orifice opening [m]
hmaximum     maximum orifice opening [m]
Amaximum     maximum orifice area [m2]
Aleakage        leakage orifice area [m2]
Leakage orifice area is for a “closed orifice”. 





Double-Acting Hydraulic Cylinder (Simple)

[image: ]
· D cylinder diameter 32 mm
· d rod diameter 20 mm
· Piston area A: pi/4*0.032^2 			(AA= /4D2)
· Piston area B: pi/4*0.032^2- pi/4*0.020^2 	(AB= AA -/4d2)
· Piston stroke: 1 m 			(maximum stroke)
· Piston initial distance from cap A: 0.8 m 		(initial position of piston)

Mass
[image: ]
















Pipe parameters

Update parameters
· Pipe internal diameter  0.012 m
· Pipe length  0.75 m

[image: ]

Ideal Translational Motion Sensor

Update parameter Initial position  0.8 m
[image: ]













Your system should look like this.			Start simulation

[image: ]


Your model should be ready for 10 s simulation. 
Use scopes
· x
· p_A
· p_B
for piston position [m], A chamber pressure [Pa] and B chamber pressure [Pa]. 

You can also test if the input commands are correct by placing a Scope between Add block and Simulink-PS Converter. 














Assignment for phase 1 – Open loop control

Make a short document (Word- > pdf)

Documentation Format:

Your name
Assignments
1. Finalize the simulation model
a. Document part 1
i. Paste a Figure of the System Model to your document
ii. Edit > Copy Current View to Clipboard > Metafile or Bitmap
2. Tune the system with valve’s zero point parameter (U_0). Adjust that parameter to keep cylinder still during zero input.
a. Document part 2
i. Give the proper parameter value for U_0
3. Plot the Piston Displacement signal
a. Document part 3
i. Copy the Scope plot and paste it into your document
ii. File > Copy to Clipboard (Ctrl-C) OR 
iii. (File > Print to Figure) OR
iv. Configuration Properties > Logging > Log data to Workspace
1. Variable name x
2. Save format: Array
3. In Matlab workspace
a. figure
b. plot(x(:,1),x(:,2));
4. Plot the Cylinder Pressure A signal
a. Document part 4
i. Copy the Scope plot and paste it into your document
ii. File > Copy to Clipboard (Ctrl-C) OR the options presented above
5. Plot the Cylinder Pressure B signal
a. Document part 5
i. Copy the Scope plot and paste it into your document
ii. File > Copy to Clipboard (Ctrl-C) OR the options presented above
6. Improvement suggestions to this Tutorial document
a. Actual errors or misprints (page and location)
b. Missing information
c. Actual improvements




Additional material
Getting started
https://se.mathworks.com/help/physmod/hydro/getting-started-with-simhydraulics.html 
Simple actuator model tutorial
https://se.mathworks.com/help/physmod/hydro/ug/creating-a-simple-model.html 


Closed loop control – assignment phase 2

Remove blocks Step 2 and U_0.

Open block Add block change the List of signs to +-.

[image: ]


Rename the block to Error. Delete Step blocks 2, 3, and 4. Delete Constant block (U_0).

Open Step 1 block. Rename it as Step and update the parameter values as in the figure below.
 
[image: ]



Update cylinder parameters
Double click Double-Acting Hydraulic Cylinder (Simple) to open it. 
Update Piston stroke and Piston distance from cap A as follows. Click OK.

[image: ]



Update also Ideal Translational Motion Sensor. Set Initial position to 0.
[image: ]

From the Simulink > Math operations bring Gain block. Place it between Error and Simulink-PS Converter as in the figure below. Name it as P gain. This is the system’s P controller (PID). 
[image: ]
Branch (mouse right button) and connect Piston displacement signal wire from block PS-Simulink Converter ….
[image: ]
to Error block’s second interface. The difference between the values tells you how far the actual position is from the target position. 
[image: ]     
From Simulink > Signal routing library bring Mux (multiplexer) block.  [image: ]

Connect Scope block to it and name it for example as Piston Displacement - Command and Position. 
Connect wire from Step block to the first interface and Piston displacement signal to the second interface.
        
	 
From: Step
	[image: ]

	From: Piston displacement (x)
	


   
From Simulink > Sinks library bring To Workspace block. 
Connect wire from Mux signal(s) to its interface.

[image: ]

Double click to open To Workspace block. 
Adjust the parameter(s) as follows > Variable name > x. Click OK.
[image: ]


Add also a Scope for valve command voltage U between P Gain and Simulink-PS Converter. [image: ]
Your system should look (something like) this.

[image: ]






Plotting of variables
File > Model properties > Model properties > Callbacks > StopFcn

 [image: ]



Add the following code to StopFcn 
close all 
figure 
plot(x.Time-3,x.Data(:,1)) 
hold on 
plot(x.Time-3,x.Data(:,2)) 
%plot(x.Time-3,1+0*x.Time) 
plot(x.Time-3,0.95+0*x.Time) 
plot(x.Time-3,1.05+0*x.Time) 
legend('command','x','95%','105%','Location','southeast') 
Click OK to confirm the changes.
























Run the model. 
You should get also a Figure like this.

[image: ]Can be also here (depending on Matlab version)
Zoom
Data Cursor





Use Zoom (In or Out) and Data Cursor tools for finding detailed information.

[image: ]

Check from the Figure or from Scope Piston Displacement - Command and Position how well the actuator follows the command. 
If the performance is poor increase the P Gain value. Raise the value boldly (decades). This is only a simulator!  
Notice that the Piston displacement signal starts to oscillate if the P Gain value is too high.
More specified servo tuning instructions below (Tuning the P controller according to Ziegler-Nichols).


Tuning the P controller according to Ziegler-Nichols
· Increase P Gain parameter value until the system starts to oscillate continuously. Use zooming!
· This minimum value of P Gain (parameter KP) is so called critical gain KP, crit. Store this value!
· (To implement controllers as PI or PID you should also estimate the time period of oscillation Tcrit corresponding this gain. This can be identified from the response  time between two successive peaks).
· P controller’s gain according to Ziegler-Nichols tuning rules is now simply 0.5KP, crit.



































Assignment for phase 2

Continue with your short document (Word -> pdf) for Phase 1

Documentation Format:

Assigments

· Finalize the simulation model
· Paste a Figure of the updated simulation model to your document
· Edit > Copy Current View to Clipboard > Metafile or Bitmap
· Test the system with critical gain and two different values for the P gain
· Pgain, 0=  KP, crit	(critical gain according to Ziegler-Nichols tuning rule)
· Pgain, 1=  0.5KP, crit	(tuned according to Ziegler-Nichols tuning rule)
· Pgain, 2=  0.25KP, crit	(smaller gain for comparison)
 
· Plot the Piston Displacement signals for
· Pgain, 0 (critical)
1. overall displacement Figure
2. zoomed Figure to see the performance near the target position
· Pgain, 1
3. overall displacement Figure
4. zoomed Figure to see the performance near the target position
· Pgain, 2
1. overall displacement Figure
2. zoomed Figure to see the performance near the target position

Analyze the plots and add information to these tables. Check the following page for Performance analysis.

P controller parameters
	KP, crit
	 
	V/m

	0.5KP, crit
	 
	V/m

	0.25KP, crit
	 
	V/m


 
Performance of P control for Pgain, 1 parameter value (0.5KP, crit)
	Overshoot
	 
	%

	Rise time 95%
	 
	s

	Settling time 5%
	 
	s

	Steady state error
	 
	m



Performance of P control Pgain, 2 for parameter value (0.25KP, crit)
	Overshoot
	 
	%

	Rise time 95%
	 
	s

	Settling time 5%
	 
	s

	Steady state error
	 
	m



[image: ]

Overshoot
The ratio of difference between output y’s first maximum and its new steady-state value to its new steady-state value (= a/b in Figure above). Sometimes this characteristic is marked with Mp, maximum percentual overshoot.
Rise time (95%)
Time it takes for the response to rise from zero to 95% of the steady-state response.
Damping ratio
The ratio of difference between output y’s first maximum and its new steady-state value to the difference between output y’s second maximum and its new steady-state value (= c/a in Figure above).
Settling time ts
The time that after a stepwise change in system’s setting value w is required for the process output y to reach and remain inside a band whose width is equal to ±5 % of the total change in y (sometimes also other bandwidths are used, e.g., ±1 %, ±2 %).
Time period T
The time between output y’s two successive peaks (e.g., first and second maximum) or valleys. 
Oscillation frequency f
The frequency that the system oscillated with (= 1/T). 
Steady state error est
The constant deviation between system’s setting value w and actual output value y. 


Valve commands [V]
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[*a] Block Parameters: Valve Actuator

Valve Actuator

This block is a simplified model of the valve actuator. The actuator is represented as the first order lag
simulated as the combination of the PS Gain and PS Integrator blocks enveloped by the unity
feedback. The PS Saturation block at the exit limits output to +/- valve stroke.

Connections I and O are the physical signal ports associated with the input and output respectively.
Positive signal at the input causes the output to move in positive direction.

Settings
Parameters
Valve stroke:
Time constant:

Actuator gain:

0.005 m v
0.002 s v
Se-4 m v

OK

Cancel Help Apply
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[*a] Block Parameters: Hydraulic Constant Pressure Source X

Hydraulic Constant Pressure Source

The block represents an ideal source of hydraulic energy that is powerful enough to maintain specified
pressure difference regardless of the flow rate through the source. The pressure difference between
ports P and T is specified with the block parameter. Block connections T and P correspond to the
source inlet and outlet ports respectively. The block positive direction is from port P to port T.

Source code

Settings

Parameters

Pressure: 120e5 Pa v

0K Cancel Help Apply
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[*a| Block Parameters: 4-Way Directional Valve X

4-Way Directional Valve

This block models the basic option of the 4-way directional valve in a hydraulic network. To
parameterize the block, 3 options are available: (1) maximum area and control member stroke, (2) the
table of valve area vs. control member displacement, and (3) the pressure-flow rate characteristics.

Ports P, T, A and B are hydraulic conserving ports associated with the valve inlet, outlet, and actuator
terminals, respectively. The control member displacement is set by the physical signal input S. A
positive displacement opens the connections between ports P-A and B-T and closes the connections
between ports P-B and A-T.

Settings
Basic Parameters ~ Model Parametrization ~ Valve Opening Offsets
Area characteristics: Identical for all flow paths °

Model parameterization: Maximum area and opening °

Flow discharge coefficient: 0.7

Leakage area: 0.45/60000/(0.7*sqrt(2*50e5/844.4)) mA2 v
Laminar transition B
specification: Pressure ratio

Laminar flow pressure ratio: |0.999

oK Cancel Help Apply
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[Pa] Block Parameters: 4-Way Directional Valve X
4-Way Directional Valve

This block models the basic option of the 4-way directional valve in a hydraulic network. To
parameterize the block, 3 options are available: (1) maximum area and control member stroke, (2) the
table of valve area vs. control member displacement, and (3) the pressure-flow rate characteristics.

Ports P, T, A and B are hydraulic conserving ports associated with the valve inlet, outlet, and actuator
terminals, respectively. The control member displacement is set by the physical signal input S. A
positive displacement opens the connections between ports P-A and B-T and closes the connections
between ports P-B and A-T.

Settings

Basic Parameters ~ Model Parametrization  Valve Opening Offsets

Maximum opening: 0.005 m v

Maximum opening area: 4))+0.45/60000/(0.7*sqrt(2*50e5/844.4)) | [m~2 -

oK Cancel Help Apply
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[%a] Block Parameters: Double-Acting Hydraulic Cylinder (Simple) X

Double-Acting Hydraulic Cylinder (Simple)

The block is a model of a double-acting hydraulic cylinder developed for applications in which only the
basic cylinder functionality must be reproduced in exchange for better numerical efficiency. For these
reasons, factors such as fluid compressibility, friction, and leakages are assumed to be negligible. The
hard stops are assumed to be fully inelastic to eliminate any possible oscillations at the end of the
stroke. The model is suitable for real time or HIL simulation if such simplifications are acceptable.

Connections R and C are mechanical translational conserving ports corresponding to the cylinder rod
and cylinder clamping structure, respectively. Connections A and B are hydraulic conserving ports. Port
A'is connected to chamber A and port B is connected to chamber B. The block directionality is
adjustable with the Cylinder Orientation parameter.

Settings
Parameters
Piston area A: pi/4*0.032°2 m~2 v
Piston area B: Pi/4*0.032/2-pi/4*0.020°2 mn2 v
Piston stroke: 1 m v
Piston initial distance from 5o m ~
cap A:
Penetration coefficient: le12 S*N/m~2 v
Cylinder orientation: Acts in positive direction °

0K Cancel Help Apply
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[*a] Block Parameters: Mass

Mass

The block represents an ideal mechanical translational mass.

The block has one mechanical translational conserving port. The block positive direction is from its
port to the reference point. This means that the inertia force is positive if mass is accelerated in

positive direction.
Source code
Settings
Parameters  Variables

Mass:

234

OK

Cancel

Help Apply
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[l Block Parameters: Hydraulic Pipeline X

Hydraulic Pipeline

This block models hydraulic pipelines with circular and noncircular cross sections. The block accounts
for friction loss along the pipe length and for fluid compressibility, and by extent of idealization it takes:
an intermediate place between the Resistive Tube and the Segmented Pipeline blocks. The block does
not account for fluid inertia. The model is built of Resistive Tube and Constant Volume Chamber
building blocks.

Connections A and B are hydraulic conserving ports. The block positive direction is from port A to port
B. This means that the flow rate is positive if fluid flows from A to B, and the pressure loss is
determined as p = p_A - p_B.

Settings
Parameters
Pipe cross section type: Circular °
Pipe internal diameter: 0.012 m v
Geometrical shape factor: 64
Pipe length: 0.75 m v
Aggregate equivalent length 1 m ~
of local resistances:
Internal surface roughness . ~
height: 15e6 m
Laminar ﬂaw upper Reynolds 2000
number limit:
Turbulent flow lower
Reynolds number limit: 4000

0K Cancel Help Apply
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[*a] Block Parameters: Ideal Translational Motion Sensor X
Ideal Translational Motion Sensor

The block represents an ideal mechanical translational motion sensor, that is, a device that converts
an across variable measured between two mechanical translational nodes into a control signal
proportional to velocity and position. The sensor is ideal since it does not account for inertia, friction,
delays, energy consumption, and so on.

Connections R and C are mechanical translational conserving ports and connections V and P are

physical signal output ports for velocity and position, respectively. The block positive direction is from
port R to port C.

Source code
Settings

Parameters

Initial position: 0.8 m v

0K Cancel Help Apply
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[*a] Block Parameters: Error

Sum
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a) character vector containing + or - for each input port, | for spacer

between ports (e.g. ++|-|++)

b) scalar, >= 1, specifies the number of input ports to be summed.
When there is only one input port, add or subtract elements over all
dimensions or one specified dimension

Main  Signal Attributes
Icon shape: |rectangular
List of signs:

-

Cancel Help

Apply
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[%&l] Block Parameters: Step
Step

Output a step.
Parameters

Step time:

3

Initial value:

0

Final value:

1

Sample time:

0

] Enable zero-crossing detection

7] oK

Interpret vector parameters as 1-D

Cancel

Help

Apply
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[%a] Block Parameters: Double-Acting Hydraulic Cylinder (Simple) X

Double-Acting Hydraulic Cylinder (Simple)

The block is a model of a double-acting hydraulic cylinder developed for applications in which only the
basic cylinder functionality must be reproduced in exchange for better numerical efficiency. For these
reasons, factors such as fluid compressibility, friction, and leakages are assumed to be negligible. The
hard stops are assumed to be fully inelastic to eliminate any possible oscillations at the end of the
stroke. The model is suitable for real time or HIL simulation if such simplifications are acceptable.

Connections R and C are mechanical translational conserving ports corresponding to the cylinder rod
and cylinder clamping structure, respectively. Connections A and B are hydraulic conserving ports. Port
A'is connected to chamber A and port B is connected to chamber B. The block directionality is
adjustable with the Cylinder Orientation parameter.

Settings
Parameters
Piston area A: pi/4*0.032°2 m~2 v
Piston area B: Pi/4*0.032/2-pi/4*0.020°2 mn2 v
Piston stroke: 12 m v
Piston initial distance from m ~
cap A:
Penetration coefficient: le12 S*N/m~2 v
Cylinder orientation: Acts in positive direction °

0K Cancel Help Apply
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[*a] Block Parameters: Ideal Translational Motion Sensor X
Ideal Translational Motion Sensor

The block represents an ideal mechanical translational motion sensor, that is, a device that converts
an across variable measured between two mechanical translational nodes into a control signal
proportional to velocity and position. The sensor is ideal since it does not account for inertia, friction,
delays, energy consumption, and so on.

Connections R and C are mechanical translational conserving ports and connections V and P are

physical signal output ports for velocity and position, respectively. The block positive direction is from
port R to port C.

Source code
Settings

Parameters

Initial position: 0 m v

0K Cancel Help Apply
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["a] Block Parameters: To Workspace

To Workspace

Write input to specified timeseries, array, or structure in a workspace.

For menu-based simulation, data is written in the MATLAB base

workspace. Data is not available until the simulation is stopped or

paused.

To log a bus signal, use "Timeseries" save format.
Parameters

Variable name:

X

Limit data points to last:

inf

Decimation:

1

Save format: | Timeseries
Log fixed-point data as a fi object
Sample time (-1 for inherited):

-1

Q oK Cancel Help

Apply
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[Pa] Model Properties: Simscape_test 2019_v1_Part2 X

Main  Callbacks

Model callbacks
PreLoadFcn
PostLoadFcn
InitFen
StartFcn
PauseFcn
ContinueFcn
StopFen*
PreSaveFcn
PostSaveFcn
CloseFcn

History  Description  Data

Simulation stop function:
close all

figure

plot(x.Time-3,x.Data(:,1))

hold on

plot(x.Time-3,x.Data(:,2))
plot(x.Time-3,0.95+0*x.Time)
plot(x.Time-3,1.05+0*x.Time)
legend('command','x','95%','105%','Location’,'sout]

oK Cancel Help Apply





image56.png
(& Figure 1 - o

File Edit View Insert Tools Desktop Window Help

NEds|k A UDRE L |a0Eed

1.2

0.8

0.6

0.4

command
x

95%
105%

0.2

-3 2 -1 0 1 2 3 4 5 6





image57.png
1.005

0.995

0.99

0.985

X:0.7839

target
95%
105%

0.8 1 1.2 1.4 1.6 1.8





image1.png
M

Pa

Ps

CONTROL

X





image58.png
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