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Parametric Transformation - Concept

Modeler Advanced has the ability to perform parametric transformations of hull shapes
using the Parametric Transformation command in the Data menu.

This process involves moving the columns fore and aft, while not changing the section
shapes (unless scaling them) I.e. all y-coordinates move by ratio of beams, all z by
ratio of drafts etc.

The transformation moves stations fore and aft until the required parameter(s)
specifications are met.

A key quality of this approach is that it maintains the fairness of the hull to a very high
degree during the transformation process.

In this tutorial we are going to employ this parametric transformation feature to
transform a parent 3D model into a geometric similar model with new particulars.

The parent ship model used in this tutorial is a cruise ship; you can also use other
parent models, like general cargo ship, ferry, catamaran, etc.
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Parametric transformation of a basic ship

« Maxsurf Modeler has many types of parametric ship models that can be adjusted to
meet the main particulars of a new design.

« Go to the installation location to check the available models (C:\Program
Files\Bentley\Offshore\MAXSURF CONNECT Edition V23\Sample Designs)

* Open Cruise ship model (CruiseShip_ Pro.msd)

A? Aalto University
[ |



Parametric transformation of a basic ship

« To show main particulars of the
parent cruise ship model

v Make sure that the grid lines
(sections, buttocks and waterlines)
and datum are defined.

v Go to Data > Calculate Hydrostatics

« Assume that Your new model has
the following particulars:

v LWL =250 m
v’ Breadth = 30 m
v Draft=7m

v Cy =0.65
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Hydrostatics at DWL *
Measurement Value Units -
1 |Displacement 67583 t
2 [Volume (dizplaced) 65934.837 m*3
3 |Draft Amidships 8.200 m
4 [Immerzed depth 8.800 m
5 |WL Length 4412 m
& |Beam max extents on 38.595 m
7 |Wetted Area 13347.020 m'2
& |Max sect area 305.423 m2
9 [Waterpl Area 872311 m'2
10 | Prismatic coeff. (Cp) 0887
11 |Bleck coeff. (Cb) 0817
12 |Max Sect. area coeff. 0.5901
13 |Waterpl. area coeff. { 0.801
14 |LCE length 157,760 from ze
15 |LCF length 138.325: from ze
16 |LCB % 50178 from ze
17 |LCF % 43995 from ze
18 (KB 5.028 m
19 |KG fluid 0.000 m
20 [BMt 15.895 m
21 |BML 850.789 m
22 |GMt corrected 20823 m
23 |GML 855.816 m
24 | KMt 20923 m
25 [KML 855.816 m
28 |Immersien (TPc) 99862 tonnelc
27 |MTe 18597.596 : tonne.m
28 |RM at 1deg = GNt.Dis! 24578.716tonne.m v
Diensity (water) |‘I.D2510nnefm"3 |
Std. densties | 1.025 tonne/m "3 - Std. Metric sea water (1025.0 kg/m"3) w
VEG Om | Recalculate
Select Rows ...
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Units...
CE Coefficients...

Design Grid...

Inclined Sections...

Frame of Reference...

Vessel Type...
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Calculate Parts
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Parametric Transformation...
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Parametric transformation of a basic ship

Data Window Help  Bentley Clouc

To create model with the new dimensions

v
v

AN

Unlock all surfaces (double click on the surfaces and uncheck “locked”)
Define the DWL and aft and forward perpendicular

presentation)

It is preferrable to do parametric transformation without superstructure

Go to Data > Parametric Transformation > Insert the new particulars (Cy or Cp, Midship
area coefficient, LCB, displacement, LWL, Beam and/or immersed depth) > Press Search
> Check the new model main parameter are defined adequately and the lines are smooth
without considerable distortion > Press Ok or search again to define new model.

(refer to “Maxsurf Modeler Basics” ;

[] Parallel midbady

ARt midbody limit

Forward midbody limit

Search For:

e ok LR “owt
) Prismatic Cosfficiert LCF aft of DWLFwd) 5704 % DWL
Midship Area Coefficient [ Topside Flare l:l Degrees

Watemlane Area Coefficient 0.2

Scale To
[] Displacement 67634t

et n L. e e

OK

B

Beam on DWL Density (water) |1.025tonne/m”3

Parametric Transformation

[ Paraliel midbody

Aft midbody limit

Search Far:

Forward midbody limit

x

@) Block Cosficient LCB aft of DWLfwd) % DWL
O Prismatic Coefficient LCF aft of DWLEwd)  56.16 % DWL
Midship Area Coefficient 050 [ Topside Flare Degrees
Waterplane Area Coefficient 0 824
Scale To:
[] Displacament Beam on DWL Density {water)
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CE Coefficients...

Design Grid...
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Calculate Offsets...
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Parametric transformation of a basic ship

The parallel midbody feature is used to keep the
midbody between the aft and forward limit as it is
while performing parametric transformations.

The parameters that can be specified are divided
Into two groups:

> Search Parameters: like C; C, and LCB. These
Parameters require a non-linear transformation of the
hull shape. As there is no explicit function of these
parameters, Maxsurf modeler performs an iterative
search to achieve the specified values.

» Scaling factors: Scaling Factors are those parameters
that can be calculated directly using a linear scaling of
the hull (as Displacement, LWL, B and Draft). These
parameters can be constrained to particular values, or
left to vary as other parameters change by selecting the
appropriate check boxes and setting the required
values.
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[1 Parallel midbady
Aft midbody limit Forward midbady limit

Search For:

@® Block Coefficient LCB aft of DWLwd) % DWL
O Prismatic Coefficient 0.687 LCF aft of DWLfwd) 5704 % DWL [E—
Midship Area Coefficient 0.501 [] Topside Flare D Degrees

Waterplane frea Coefficient 0.8

Scale To:

[] Displacement Beam on DWL Density (water) |1_1]25tonne,-fm"'3
g o S

oK Cancel




Parametric transformation of a basic ship

. . . . . . Hydrostatics at DWL e
« The parametric variation tool Iis ideal for making small
. . . . . Measurement Value Units Fs
adjustments from a suitable parent design. It is not intended tO [T [pspacenen T T
) L. . 2 |Volume (displaced) 34120037 m'3
be used for gross design modifications. 3_[Draft Amidships 700 m
4 |lmmersed depth T.000 m
H H H H 5 |WL Length 250000 m
« Thereference point and the design grid should be redefined S bean ma s on " B8 eT
. T |Wetted Area 8417.3580 m*2
« Now you can calculate the new hydrostatics of the transformed [z uesect o il w2
9 |Waterpl Area 51596.424 m'2
10 |Prizmatic coeff. (Cp) 0.723
m 0 d el 11 |Block coeff. (Cb) 0.650
o 12 |Max Sect. area coeff. 0.5301
* Go to Data > Calculate Hydrostatics... T3 [Watorp area coeft. (0,628
14 |LCB length 122.541 : from ze
Data Window Help Bentley Clo 15 |LCF length 109.245 : from ze
&7 Units... 15 [LCB % 45.016 ; from ze
CB Coefficients... 17 |LCF % 43693 from ze
i Design G, 18 |KB 3.973 m
:/ Inclined Sections... 18 |KG fluid -1.800 m
EZ Frame of Reference... 20 |BMt 11.982 m
@ Vessel Type... 21 |BML §95.797 m
= Windage Surfaces... 22 |GMt corrected 17.754 m
le, Target Section Area Curve... 23 |GML T01.570 m
L4 Girth... 24 KNt 15.854 m
ET) Calculate Offsets... 25 |KML 899.770 m
f\ Go To Offset... 28 |Immersion (TPc) 63.513 ! tonnelc
j'-l'l, Go To Previous Offset 27 |MTe ga1 450 tonne.m
DH 2°|T°l“ta‘;°”*t 28 |AM at 1deg = GMtDis:  10835.531 tonne.m v
| : :Ik:lz:::::mu Density (water) |1.ﬂ25tonne;"m"3 |
L4 Parametric Transformation...
. ACRule.. Std. densties | 1.025 tonne/m "3 - Std. Metric sea water (1025.0 kg/m"3) v
Calculate Parts r
£} Verify Model... VCGE -1.8m | Recalculate

Select Rows ...
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Amending hull form manually

« The shape of the hull, pulpous bow or stern can be amended easily by manipulating the

position of the nearest control points
Make sure that the surface is unlocked (double click on the surface and uncheck Locked)
Activate surface Net ( Display >~ Net > activate Rows and Columns)
Then manipulate the control points to get the desired shape (Use the appropriate view to ease the manipulation of

the control points).

™~

Display Data  Window

Met

Profile view
Shortening the length of th

LW Half

=, Compress
Curvature
Trimming
Precision

R Drawing Settings...

lePulpous bow

Fl

BESE”"‘%

B

Help
M Hide Net
X Hide Curve Net

Bentley Cloud Serv

'f':'ﬁ Rows

S Columns

Surface Properties

Surface Name: |
Geometry: Viewing and Appearance: Material:
%;?_:;Twe Surface Flags: Group:
ine
Mo Material ~
(JJNURB Visible
(O conic [JLocked Material:
(_) Developable Symmetrical Mo Material
Surface stiffness: Split Section Display _
Longitudinal Thickness: amm
e Direction:
Transverse : (O projects inside of surface
3 (Aexible) ~ (Ois centred around surface
(®) projects outside of surface
Surface Use: Transparency:
%
(O Internal Structure Cutting Curves and Surfaces. ..

Cancel




Amending hull form manually

N —
) ~ —

I e————

|
///

Profile view
Submerging|the transg

ern slightly

"FHBO water

]
_/

Check the presentation “Ice Breaker from lines plan” for more information about manipulating the
control points and surface forming.
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Hydrostatics

Maxsurf Stability can be employed, to plot hydrostatics curves.
Save the model in Maxsurf modeler
Open Maxsurf stability
Go to File > Open Design > and open the modified model.
If it is the first time to open the model in Maxsurf Stability, the first

option “ read existing data” should not be active (Next time you can
select this option to open the saved stability file)

From stations, select the appropriate number of stations that will be
used to calculate ship hydrostatics. It depends on the ship length and the
ship geometry. Increasing the number of stations will increase the
required analysis time.

Section Calculation Options *

Read existing data and sections Surface precision
(do not update geometry) (O Lowest
Calculate new sections OLow
{ignore existing data, if any) (®) Medium

[Jindude skin thickness (O High

Use trimmed surfaces (O Highest

Stations:

(") Use Model Design Grid station positions
(®) Low number of stations (approx. 50)
(") Medium number of stations {approx. 100)

Select Surfaces
(O High number of stations (approx. 200)
? Aalto University () Highest number of stations {approx. 500)
—

24 MAXSURF Stability Enterprise C

File = Edit View Case
Mew Ctrl+M
& Open Design... Ctrl+0

s Close Design

H Save Design Ctrl+5

l—_; Save Design As...

Import
Export

Criteria

Load Densities...

Save Densities As...

=) Page Setup...
=] Print... Ctrl+P

Recent File

() Exit
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Bentley Cloud Services

Help

Data  Window

Go to Display > Visibility > Sections

Display

Hydrostatics

To show the stations that will be used in hydrostatics calculations

ﬂ.—.

o, :
=) %) | Haomme Perspective

> Oc
S =B e e

Waterlines

() Internal Edges
[ Z Feature Edges
i~ Bonded Edges
= Waterplane
<1 Key Points
= Margin Line

U Sections
=]

Data Format...

» [= Hull Edges

]
¥

Set vessel to DWL

Select View from Data
Visibility

Windage Profile...

Damage Zones/Extent
Individual Loadcase masses
Background

Design Grid

Render Transparent

IJ Show Single Hull Section in Body Plan
Render

& Animate (Shift to save)
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Hydrostatics

Now we need to define the range of draft for hydrostatics calculations:
Go to window > Upright Hydrostatics (Or select it from Analysis tab)

Window Help  Bentley Cloud Services

GO tO AIlalySiS > Draft.. Cascade Home Perspective ~ |1
Tile Horizontal
Define initial draft amidship, Final draft and draft increment or number of™ mevete -
Arrange lcons :
drafts = [ See|ao
Restore Default Layout -
Define VCG and LCG if available unless the calculations of GM will be not viewoiesoen ,
accurate. Loadcase »
Darmage ¢
Press Ok Input »
. o o . . Besults v [ Upright Hydrostatics
You can instead define range of displacement from Analysis > Displacement.. Craph y \E Lauge Angie Sabiy
Analysis Results Display Data Window Help v lPETSFIECti\"E EqU”lb”Um .
Draft HEHQE o e Specified Condition
S Terera KM values
N o A Limiting KG
Initial draft amidships om . P Floodable Length
5 Results
Calibration Options... i i
Final draft amidships 10 m NAROL Ot 6 Graph :;gngltl'fc.lm.al N
Cross Flood... 7 Report robabilistic Damage
Draft increment 1m = Tank Callhr.atn:un
i Waveform.. == MARPOL oil outflow
Zero pt. ]
NLIIT||:IEF Df draﬂ:s 1 1 %ﬁ E'ruutge::d = Upright H)rdmstatics Empt;.'b e qi:::f:' Frnes: e ~
Grounding... Ulihl drostatics T
ErEllaE Large Angle Stability "
LCG from zero point 161,788 m T Analysis T
) - g ) KN Values s
Aalto Univ RE[E‘[UhtE.HL!” Sections... . Limiting KG n cl ySIS ap
A? ‘.I l|||l|:G ﬁ—l:lm ZEro |:||:|||'|t B,B i Snap Margin Line (or selected key points) to Hull [|DDE|:E‘LE Lelnsgth .
et Analysis Type ongitudinal Streng _
= s
Resume Hydrostatics il Qutflow
Ok Cancel Rl ETe yrﬁ?igltgdl 35?352(92)
[ Start Batch Analysis




Hydrostatics (Results)

To Calculate the hydrostatics Go to Analysis > Start Hydrostatics.
To show the tabulated results at different drafts:

Analysis  Results Display Data Window
Heel...
Trim...
Draft...

Displacement...

BEER

Specified Conditions...
Permeability...
Calibration Options...
MARPOL Options...

Cross Flood...

Fluids...
Density...
Waveform...
Hog and Sag...

“CE®™

Criteria...
Grounding...

Water on Deck...

Update Loadcase
Recalculate Tanks and Compartments
Recalculate Hull Sections...

Snap Margin Line (or selected key points) to Hull

Set Analysis Type
(5 Start Hydrostatics
= Resume Hydrostatics

Lo

Stop Hydrostatics

D Start Batch Analysis

Help

Y o

Go to Window - Results..

Window  Help  Bentley Cloud

H 3O

Cascade
Tile Horizontal
Tile Vertical

Arrange lcons
Restore Default Layout
Yiew Direction ¢

Loadcase *
Darnage J

Input ¢

Results *

Graphs J

1 Perspective
2 empty LC 1
3 Damage

4 Input

5 Results

& Graph

7 Report

Ll A':'ﬂ“’“""“ 0.000 | 1.000 | 2000 | 3.000 | 4000 | 5000 | 6000 | 7.000 | 8000 | 9.000 | 10.000
1 Displacement t D.0000] 3488  O165: 18023 23681 31932, 40718 45094 50654 69573, 79565
z Heel deg iXi id i (i iXi id i (i iXi id i
3 Draft at FF m foa0: 160 Fa00 T 96004000 Shon; Edoo’Fono: odo: eb66 10 oo
2 Drafi at AF m foa0: 160 Fa00 T 96004000 Shon; Edoo’Fono: odo: eb66 10 oo
) Draft at LCF m goo0: 1ot Zoooi 3ooo.4den swod: TegootFooa: sooo: g0 10000
6 Trim (+ve by stern) m o.000f oo ooooi oooo occoi omod: ocoo ooooi  oooo: ooodi o000
7 WL Length m 1262021 2342441 307279 32778 3128000 3127681 3129231 312337 314670 3135471 310,088
8 Beam max extents on W 0.000: 27.857: 32791 35443 36775 375821 38000 35401, 38556 35600, 32800
5 Wietted Area mes 00004877 659 6355 50817540 310 B555 24010538 151 1089388119500 77 12443 7013370 06119034 44
10 |waterpl Area mh2 0000 4855 350° 6150 44717133 385 7780 04718317 796 B8 56310044 310 6580 743 9748 83T 9TEE 7T
1 Frismatic coeff. (Cp) Bo00: oeez D EEETTOETE o0 s T e eET T T ieT T oe T i 2
12 |Block coeff. (Cb) T T A WY VS B 0 R - NV R TS T 1T L - CE R Y-
13 |Max Sect area coeff. (| D.000: o788 0E02]OEIE 0897 0EE4T o’ UOERG T 0EeR o0sl oe13
18 |Waterpl area cosft (G Bo00: o T OES T 0EA T ETT O 0T o e R F T 0 e0 T 0804 T 0 E1E
15 |LCH from zero pt (+ve £ B734T 1828131787791 174658 1716907 168 7847 1A5 995 163 008 160 088 157 184 154778
16 |LCF from zero pt. (+ve £ B 7341 1781317 173051 T 187 143 185 839 15 554 e 841 4T F09 T 142 95E Y B8 19 45T
17 |KEm I IR T v S T P T e 1 e Wt R S R R H
12 |KGm 38000 e300i s00) sg00 es00; ss00 es00i seoossc0 800 800
19 |BMtm 00007 73537 48354l 38776 31145 28051 22539 198800 17591, 154741 13533
20 |BMLm 00004394 6012520 7821 1885 509 1510 6421 1276 098 1146023 1036 611, 9408231 8276231 727158
3 Gt m B R L R Ul ST R Y- H R VR T TR AT A - v B KRy R - U E T v
3 |GHlm 337 A986 307 3575 14011875 457 TE04 155 13T 078 1141 568 1037 835 936 02§35 865 TR 04s
33 |KWtm T T T T R W Y T L i .y CH - R P S i1 -V LY
52 |KMLm 148314905 197 5551 948 1887 255 515 555 1579 578 1150966 1040 655|948 405 35 TES T TaT as
35 |immersion (TPc) tonnere.  0.000° 485017 E3480° 108 Foad7 ESge o0 d7rl oaTed U9En03 ] on ezl oo ozs
38 |WiTe tonne.m 00007 B02 1507 TEE 704 T 087 448 118528 1331 627 1505 087 1885 433 1893 085 1350 903 1850 048
57 |AMaiideg < Gt Disp. 0 000 3878 057 A759 5468866 543 10191 43 11318 BT 12513 07 15151 95 15850 34 14944 5L T aBAE Y
38 |Wlax deck incination deg  0.0000° 0.0000¢ 0.6660° 60060, o6oo0; donoo dogoo: o066 0 doon: bo6oo: o oooo
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Hydrostatics (Results)

The graphical representation of the results can be illustrated from:
« Window > Graph..

Hydrostatics .
= Displacement Window  Help  Bentley Clouc
I Vax sect. area
I Sect area amidships Cascade
I \Wetted Area .
[ Waterpl. Area Tile Horizontal
CTILCB _
CILCF Tile Vertical
EE KB
= KMt Arrange lcons
c O KML
CJImmersion (TPc;
& == MTe (TP Restore Default Layout
a
Yiew Direction *
Loadcase ¢
Darnage ¢
Input 4
! : / : : : : : : : : ; Besults 4
1 S e e N T - 1= - - = - T T S Rt T S el
10000 20000 30000 40000 50000 60000 70000 80000 90000 100000 110000 120000 G h "
Displacement t Lrapns
0 2000 4000 6000 8000 10000 12000 14000 16000 18000 20000 22000 24000
A -
: : ‘ ‘ : , Area m"2 : : : ‘ : , 1 Perspective
125 130 135 140 145 150 155 160 165 170 175 180 185
Long. centre from zero pt. (+ve fwd) m 2 em F't_'f‘ LT
0 0.5 1 15 2 25 3 35 4 45 ] 5.5 6 -
. . ‘ ‘ . . KB m . . . ‘ . . 3 Damage
15 20 25 30 35 40 45 50 55 60 65 70 75
KM trans. m 4 Input
400 800 1200 1600 2000 2400 2800 3200 3600 4000 4400 4800 5200
KMlong. m 5 Results
45 50 85 60 69 70 75 80 89 90 95 100 105
Immersion tonne/cm 6 Graph
400 600 800 1000 1200 1400 1600 1800 2000 2200 2400 2600 2800
Moment to trim tonne.m 7 Report
Draft = 1.000 m

Displacement = 3489 116t
-_—
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Hydrostatics (Results)

To show curves of form, change the type of curves from the tab above the Graph window

Curves of Form

Curves of Form

Hydrostatics W Hydrostatics
: : 3 ; ; Curves of Form
Curve of Areas 1 Prismatic coeff. (Cp)
Curves Curve of Areas I Block coeff. (Cb)
Bonjean Curves R S R S i | Max Sect. area coeff. (Cm)
: : | : (I Waterpl. area coeff. (Cwp)
. ' i-.-“-.-'aterpl. are cioef‘f. (Cwp)
£ coeff.é(Cm)
% B
=)
L L a et Y e  RIGGEEECOUEELLN] SERPRERERERPERREE f AL PRREERES SRR TORRE R PR
A 1 o B R EEE LR R LR R L EE PP e R e T
3_ e P P P e B R e e e L T
B R TR A e e
] ; ; ; i 3 i L
EJA n45 0.5 055 06 0.65 07 0.75 08 0.85 09 095

Coefficient

Draft= 1.000 m Prismatic coeff. (Cp) = 0.662



Hydrostatics (Results)

You can also show the curves of areas and Bonjean curves from the same tab.

LC1

Draft Amidships 10,000 m

N /Erame ofeference po -

; Sectional Area Curve
i\ Area
; Frame of Reference

| 777777777777777777 To change the draft

. of the curve of area

[a)
(=
[=]

___________________________________________________________________________________

__________________________________________________________________________________

__________________________

Area m"2

1601+

120+

807

-----------------------------------------------------------------------------------

---------------------------------------------------------------------------------

_________________________

401 / """""""" I S S R b N S i
i 40 a0 150 160 200 240 : ;

260 320 360
Station Position m
Area = 0.000 m"2 Station Position = 0.400 m




Hydrostatics (Results)

Bonjean curves

36

Draft m

Hoo

st1=0.000m

0 100 200 300 400 500

Immersed Area = 0.000 m"2

600 700 800 900 7000 17100 1200 1300
Immersed Area m"2

Bonjean Curves
. st 2
I st 3
[ st 4




