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SWMM TUTORIAL FOR URBAN RAINFALL-RUNOFF AND LID 

SIMULATIONS 
This document contains the basics of using SWMM in urban hydrological modelling and LID design 

for the Hydrological Modelling Course. SWMM is a freely available software with easy-to-read, up-

to-date manuals, therefore it is easy to gain a deeper understanding about the model on your own. 

During the course, the examples given in this document are detailed enough for students to conduct 

their own urban hydrology/LID exercises to pass the course. Further information can be found in the 

SWMM manuals: 

SWMM user’s manual: This manual includes the basic information and step-by-step guidance on on 

how to use the model:  

Rossman, L.A. 2015. Storm Water Management Model User’s Manual Version 5.1. EPA-600/R-

14/413b. Available online: https://nepis.epa.gov/Exe/ZyPDF.cgi?Dockey=P100N3J6.TXT 

SWMM hydrology reference manual: This reference manual includes detailed information about the 

computation of hydrological processes in SWMM: 

Rossman, L.A., Huber, W.C. 2016a. Storm Water Management Model Reference Manual Volume I 

– Hydrology (revised January 2016). EPA/600/R-16/093. Available online: 

https://nepis.epa.gov/Exe/ZyPDF.cgi?Dockey=P100NYRA.txt 

SWMM water quality reference manual: This reference manual includes detailed information about 

the LID modelling with SWMM and provides e.g. example parameter values for different LID units: 

Rossman, L.A., Huber, W.C. 2016b. Storm Water Management Model Reference Manual 

Volume III – Water Quality. EPA/600/R-16/093. Available online: 

https://nepis.epa.gov/Exe/ZyPDF.cgi/P100P2NY.PDF?Dockey=P100P2NY.PDF 

SWMM hydraulics’ reference manual: This reference manual includes detailed information about 

the hydraulic modelling with SWMM: 

Rossman, L.A., Huber, W.C. 2017. Storm Water Management Model Reference Manual Volume 

II – Hydraulics. EPA/600/R-16/093. Available online: 

https://nepis.epa.gov/Exe/ZyPDF.cgi/P100S9AS.PDF?Dockey=P100S9AS.PDF 

TEMPLATE FILES FOR THIS TUTORIAL AND THE WEEK’S ASSIGNMENT 
To start working, download the model and data files described below from the 

MyCourses/Assignments-page and save them to your computer: 

- Urban_hydrology_example.inp (an example model file for traditional development) 

- Urban_hydrology_example.ini (a settings file) 

- Urban_hydrology_example_LID.inp (an example model file added with LID examples) 

- Urban_hydrology_example_LID.ini (a settings file) 

- climate2005.dat (a climate file for summer 2005) 

- climate2006.dat (a climate file for summer 2006) 

- storms2005_10MIN.dat (rainfall data for June-August 2005 with 10-min time interval) 

- storms2006_2MIN.dat (rainfall data for June-August 2006 with 2-min time interval) 

The examples of this tutorial are based on the SWMM files Urban_hydrology_example.inp and 

Urban_hydrology_example_LID.inp. These files include SWMM-models of a residential area with a 

traditional pipe sewer system for surface runoff. The latter file, Urban_hydrology_example_LID.inp, 

includes examples of Low Impact Development (LID) units implemented in the existing urban area. 

Their .ini-files (the same file name except its extension is .ini) include saved settings for the SWMM’s 

https://nepis.epa.gov/Exe/ZyPDF.cgi?Dockey=P100N3J6.TXT
https://nepis.epa.gov/Exe/ZyPDF.cgi?Dockey=P100NYRA.txt
https://nepis.epa.gov/Exe/ZyPDF.cgi/P100P2NY.PDF?Dockey=P100P2NY.PDF
https://nepis.epa.gov/Exe/ZyPDF.cgi/P100S9AS.PDF?Dockey=P100S9AS.PDF
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graphical user interface. The model can be run without an ini.-file; however, it will use the default 

graphical settings. 

In addition to the above model and data files, you will need to download a template file for your 

own design exercise. Guidance on how to select your catchment file will be given during the lecture 

or in MyCourses. There will be three catchments available: Catchment1.inp, Catchment2.inp, or 

Catchment3.inp. Remember to download the associated .ini-file, too.  

PART 1: RAINFALL-RUNOFF MODELLING IN SWMM 

STUDY AREA 
Vallikallio is a medium-density residential area in Espoo. An illustration of the catchment’s land 
cover, sewer network and the catchment outlet are shown in Figure 1. Vallikallio’s landscape is 
characterised by three to four storey apartment buildings with asphalt streets and parking areas. A 
subsurface pipe sewer network covers the whole catchment being the only route for the conveyance 
of surface runoff away from the catchment area. Traffic-related areas and the majority of the 
rooftops are directly connected to the pipe sewer system. Total area of the catchment is 11.4 ha, of 
which 34% is covered by asphalt surfaces (Table 1). Vegetated areas mainly consist of lawns and 
shrubs near the buildings and natural pine forest. Some scattered gravel/sand surfaces are located 
within building yards, e.g., playgrounds. Soils within the catchment mainly consist of sandy till 
including areas with only a thin (<1 m) soil layer on top of the bedrock and areas with steeper layers 
of sandy till.  

 

Figure 1. Surface types in Vallikallio and the locations of the sewer network and the catchment outlet. This map was 
obtained from the MSc thesis of Raudaskoski (2016) (available at: https://aaltodoc.aalto.fi/handle/123456789/19943, in 
Finnish). More recently, Tuomela (2017) built a water quality model for the same study catchment (available at: 
https://aaltodoc.aalto.fi/handle/123456789/28476, in English). 

Asphalt

Stone/tiles paving

Open rock

Gravel/sand

Vegetated area

Roof

Rain gauge

Sewer manhole

Sewer pipe

Catchment outlet

https://aaltodoc.aalto.fi/handle/123456789/19943
https://aaltodoc.aalto.fi/handle/123456789/28476
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Table 1. Proportions of different surface types of the total catchment area and some key parameter values in SWMM used 
in the example model files. 

Surface type Area (ha) Area (%) 
Imperviousness 

(%) 
Depression 

storage (mm) 
Manning’s 

roughness (-) 

Asphalt 3.94 34.6 95 0.5 0.014 
- vehicular streets 0.73 6.4 95 0.5 0.014 
- walkways 1.66 14.6 95 0.5 0.014 
- parking lots 1.55 13.6 95 0.5 0.014 

Roof 2.15 18.9 100 0.3 0.01 
Gravel/sand 0.73 6.4 33 1.5 0.03 
Paving (tiles, stones) 0.24 2.1 85 0.7 0.02 
Vegetation 4.30 37.7 0 2.45 0.5 
Open rock 0.04 0.004 100 3.16 0.05 

Total catchment area 11.4 100    

OPENING THE MODEL 

➔ Open SWMM: find EPA SWMM 5.1 folder in your computer’s Start Menu, select  EPA SWMM 

5.1 

➔ After the program opens: from the top-left corner of the Main Menu , select File -> Open and 

browse the location of the Urban_hydrology_example.inp. Open it. 

➔ When working with SWMM, remember to save your work regularly: from the top-left corner, 

select File -> Save or click the  button.  

MODIFYING THE MAP VIEW 
After opening the Urban_hydrology_example.inp, adjust map settings using the Map Browser panel. 

Select Map -> select a theme from Subcatchments menu -> Imperviousness. For the design 

assignment, there are two useful subcatchment themes: Imperviousness and LID usage. The 

Imperviousness theme visualizes the different surface types according to their imperviousness 

(Figure 2). The LID usage theme helps to identify subcatchments with LID units.  

 

Figure 2. When you open a SWMM file (.inp file), you’ll see a completely black map. Use Map Browser Panel to select 
different themes to illustrate your study area (no theme is selected as default). In the current exercise, choose 
Subcatchments -> Imperviousness. 
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SUBCATCHMENT PROPERTIES 
In the example model files, each subcatchment represents one land cover type: asphalt surface, 

roof, tile/concrete paving, gravel/sand surface, open rock or vegetation. Each land cover type is 

defined with several parameters, for which the key parameters are as follows: 

- Imperviousness (%): the percent imperviousness of the subcatchment – rainfall falling on the 

impervious proportion of the catchment generates surface runoff. Infiltration only occurs from 

pervious areas. Affects the volume of surface runoff. 

- Manning’s roughness (-): the value of n (i.e., roughness parameter) in Manning’s equation for 

surface runoff. Another important variable is the Manning’s roughness coefficient for sewer 

pipes. Affects the shape of the runoff hydrograph.  

- Depression storage (mm): The depth of depression storage on impervious and pervious surfaces, 

includes the initial abstractions (surface wetting and ponding, interception) that must be filled 

before surface runoff occurs. When the depth of water exceeds this storage, any excess rainfall 

will produce surface runoff with an outflow rate given by Manning’s equation. Affects the volume 

of surface runoff. 

- Infiltration: infiltration to the unsaturated soil zone of pervious subcatchment areas. In the 

template files, the Green-Ampt method is chosen for modelling infiltration. Affects the volume of 

surface runoff. 

The parameter values for different land cover types in the template models are shown in Table 1. 

Typical parameter values can also be found from the SWMM’s User manual (Rossman, 2015). It is 

not necessary to change the subcatchment properties when working with the course assignment. 

 

 

 

 

There are two ways to select a subcatchment and 

explore its properties: 

➔ From Project Browser panel: select Project -> 

Hydrology -> Subcatchments -> select the 

subcatchment from Subcatchments list, press 

 
➔ OR: From the map view: select a 

subcatchment by right-clicking it’s square 

symbol and select Properties 
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The Subcatchment Editor window for the Subcatchment s265

  

 

 

 

 
 

 

 

 

 

RUNNING A SIMULATION 
To run a simulation, go through the following steps: 

STEP 1. Provide rainfall data. 

STEP 2. Provide climate data. 

STEP 3. Set simulation options. 

STEP 4. Run a simulation. 

STEP 5. View the simulation results. 

Tag: Subcatchment’s surface type 

Name: Name of the subcatchment 

Outlet: Outlet for the subcatchments 

surface runoff: it can be another 

subcatchment or a sewer node/junction 

(here the sewer junction j38) 

% Imperv: Subcatchment 

imperviousness 

N-Imperv/N-Perv: Manning’s n for 

impervious and pervious surfaces 

Dstore-Imperv/Dstore-Perv: The 

depth (mm) of depression storage 

Infiltration: The method for the calculation 

of infiltration: by selecting this, you can 

access the parameter values used for the 

calculation of infiltration 

LID Controls: The number of LID 

units assigned to this subcatchment 
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STEP 1. PROVIDE RAINFALL DATA 
In SWMM, a user-defined time series is a good option for event-scale simulation with short-term 

rainfall data whereas an external data file is better for long-term continuous simulation. For the 

week’s assignment, rainfall data is given both as external files (3-month continuous rainfall data 

storms2005_10MIN.dat and storms2006_2MIN.dat) and as separate time series created using 

SWMM’s Time Series Editor. In the template files, there are four ready-made time series (as shown 

in Figure below) that represent typical 10-minute design storms for sewer design with different 

recurrence intervals (the recurrence intervals of 2, 5, 10 and 50 years). Of the time series given, the 

5-year design storm represents the common design storm in sewer sizing in Finland (about 10 mm of 

rainfall within a 10-minute period).  

TO ADD RAINFALL DATA FOR A SIMULATION: 

From the Project Browser panel, select Hydrology -> Rain Gages to open Rain Gage Editor.

In the Rain Gage Editor, set the properties for a 

rain gage named r1 as follows: 

- Rain Format VOLUME 

- Station ID STA01 

- Rain Units MM 

Selecting a data source: 

➔ Select TIMESERIES from the Data Source 

dropdown menu 

➔ Use Series Name field to select the name 

of the time series 

OR: 

➔ Select FILE from the Data Source 

dropdown menu 

➔ Select the File Name data field and search 

the right file using the standard Windows 

File Selection dialog 

➔ Click open to select the file and close the 

dialog.  

Finally, set Time Interval equal to the time step 

of the rainfall data used: 2 minutes (00:02:00) 

for the time series and the file 

storms2006_2MIN.dat, 10 minutes (00:10:00) 

for the file storms2005_10MIN.dat. 

 

 

To modify or create time series:  

➔ select Time series from the Project panel 

➔ press  to modify an existing time series  

➔ press  to add a new time series. 
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STEP 2. PROVIDE CLIMATE DATA 
For the course assignment, the climate data for the calculation of evaporation is given as external 

files that can be downloaded from the MyCourses/Assignments-page. Use climate2006.dat with the 

2006 rainfall data and climate2005.dat with the 2005 rainfall data. The climate files include 

minimum and maximum daily temperatures that SWMM uses to estimate potential daily 

evaporation rates. If you are simulating the design storm time series, you can choose either one of 

the climate files. 

ADDING CLIMATE DATA FOR A SIMULATION: 

From the Project panel, select Climatology -> Temperature and press  to open Climatology Editor

On the Temperature page: 

➔ select External Climate File 

➔ press  and search the right file using the standard Windows File Selection dialog 

➔ click open to select the climate file.  

On the Evaporation page:  

➔ select Temperatures as a Source of Evaporation Rates  

➔ check that Evaporate Only During Dry Periods box is selected 

➔ select ok to close the editor. 
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STEP 3. SET SIMULATION OPTIONS 
 

From the Project panel, select Options -> 

General and press  to open Simulation 

Options Editor  

 

 Check the following settings on the General page: 

➔ Process Models: Rainfall/Runoff and Flow 

Routing selected 

➔ Routing Model: Dynamic Wave selected 

➔ Infiltration Model: Green-Ampt selected 
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Set the simulation time on the Dates page according to your rainfall data file and the purpose of the 

simulation. Below the only difference between the design storm simulation (A) and the simulation 

with the long-term rainfall data (B) is the end date in the End Analysis on field: 06/02/2006 for a 

design storm and 08/31/2006 for the summer 2006 rainfall data. If you are running a simulation with 

the summer 2005 data, remember to change the year to 2005. 

A) Simulation with a design storm      B) Long-term simulation with rainfall data  

  

Check the following settings on the Time Steps page: 

➔ Reporting time step depends on the purpose 

of the analysis. The basic setup is to set it 

equal to the time step of the rainfall data 

used: 2 minutes for 2006 data and the design 

storm time series, 10 minutes for the year 

2005 rainfall data. If the purpose is to 

determine water balance components for 

long-term time periods, larger reporting time 

steps (e.g. 1 h or 1 day) can be used. For the 

analysis of short-term peak flow rates, small 

reporting time step is required. 

➔ Runoff: Dry Weather 01:00:00 (1 hour) 

➔ Runoff: Wet Weather 00:00:05 (5 sec) 

➔ Routing: 5 seconds  

➔ Press ok to close the Editor.   

Note: the computational time steps will affect both the time it takes to run the model and the 

magnitude of continuity errors. 5 secs for wet weather runoff and routing work well with short 

design storms, but can make the computation too slow, when the long-term rainfall data is used. 

Hence, you may use 15 sec time step for long-term simulation to speed up the process.  
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STEP 4. RUN A SIMULATION 

To run a model, click the lightning button  on the SWMM’s Standard toolbar (or select Project -> 

Run simulation form the Main Menu).

 

STEP 5. VIEW THE SIMULATION RESULTS 
After the model run is completed, SWMM displays a Run Status stating whether the run was 

successful or not. For a successful model run, also the mass continuity errors for both surface runoff 

(the hydrological catchment model) and flow routing (routing of runoff through the pipe sewer 

system to the catchment outlet) are shown. Continuity errors simply show the percent difference 

between the initial storage + total inflow and the final storage + total outflow for the total 

catchment area and drainage system. Large continuity errors (for example errors larger than 5%) 

require checking the validity of the analysis results.  

There are several ways to view the simulation results. More information about viewing the results 

can be found in the SWMM’s user manual (Rossman, 2015), Chapter 2.5, Chapter 2.7, and Chapter 9.  

VIEWING THE STATUS REPORT 

To view the status report, select Report -> Status from the Main Menu. The status report shows the 

basic information about the quality of the model run and e.g. the mass balance components for the 

complete model run (Figure 3 and Figure 4). Based on the status report extracts, there was a 

considerable difference in total rainfall between the summers 2005 and 2006: it rained only 52.4 

mm during the summer 2006 (Figure 3), which is only 15% of the total rainfall in the summer 2005, 

347.6 mm (Figure 4). In the 2006, 34.1 mm of rainfall was lost through evaporation and infiltration, 

resulting in 18.2 mm of surface runoff. This comprises 35% of the total rainfall during that period. 

However, during the wet summer 2005, 49% of the rainfall produced surface runoff. This surface 

runoff volume, 169.2 mm, is ninefold compared with the surface runoff volume in the summer 2006.  

  
Figure 3. An extract of the status report (select Report -> Status) when using the rainfall data from the dry summer 2006.  

  
Figure 4. A status report extract when using the 10-min rainfall data from the wet summer 2005. 



12 
 

VIEWING THE SUMMARY REPORT 

To view the Summary Report, select Report -> Summary from the Main Menu. The Summary Report 

displays summary results for each subcatchment, node and link in the drainage system. When using 

the example model files, summary results are available for the subcatchments s3-s612, individual 

sewer pipes as links (Conduits c1-c43), and for each node including junctions representing the sewer 

manholes (Junctions j1-j44) and one catchment outlet node (o1). By changing the Topic in the 

Summary Report window, various results for different variables can be shown. 

In  Figure 5, a view of the summary report for Subcatchment Runoff is shown. In  Figure 5, Total 

Runoff exceeds total precipitation for some subcatchments. This is because these subcatchments 

receive runoff from other neighbouring subcatchments: the amount of this additional runoff is 

shown as Total Runon. The table also shows important details about the catchment hydrology: the 

total amounts of evaporation (Total Evap, mm) and infiltration (Total Infil, mm) and the highest peak 

flow rate (Peak Runoff, l/s) during the simulation period.    

 
Figure 5. An extract of a model summary report (select Report -> Summary) for Subcatchment runoff. 

Figure 6 illustrates another example of the summary report for Node Flooding. This lists all nodes 

that flooded during the simulation period. SWMM reports flooding when the water depth in the 

node exceeds the maximum assigned depth, hence, there is not enough capacity in the pipe system 

but water raises to the ground surface level. In Figure 6, the duration and magnitude of such 

flooding is rather small during the simulation period. By default, SWMM excludes the flooded water 

from the system. This can be changed by allowing ponding in the Simulation Options Editor, so that 

the water is stored atop the node and released back into the sewer system when capacity exists to 

do so. 

  
Figure 6. An extract of a model summary report (select Report -> Summary) for Node Flooding when using the 2-min rainfall 
data for the summer 2006 
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COPYING THE SUMMARY REPORT DATA TO EXCEL 

To copy data from a summary report, select Edit -> Copy to -> Clipboard from the Main Menu. Open 

an Excel file, select a cell and paste the data on a worksheet.  

 

COPYING THE DETAILED CONTINUOUS DATA TO EXCEL 

It is possible to copy detailed continuous simulation data for any subcatchment, node or link to Excel 

for further viewing and analysis. First, select Report -> Table -> By Object from the Main Menu.  

➔ In the Table by Object Selection window,  

adjust the Start Date and the End Date for    

the wanted time series.  

➔ For Time Format, select either the Elapsed 

Time from the start of the simulation or the 

Date/Time format.  Elapsed time is quite 

appropriate for short design storms, whereas 

Date/Time may suite the long-term simulation 

better. 

➔ From the Object Category, choose the object 

type: in the Figure on the right, Nodes are 

selected. The easiest way to select a node is   

to left-click it on the map window and then 

click the   button. Here the time series of 

Total Inflow to the Node o1 is selected, hence , 

we will obtain a data table containing the 

continous time series of flow rate (l/s) at the 

catchment outlet.  

 

 

 

After the data table is created, select Edit -> Copy to 

-> Clipboard and paste the data to an Excel file. 

 

 
CREATING GRAPHS 

You can always create graphs from your data by copying it to Excel and by adding and editing graphs 

using the Excel’s plotting tools. However, it is also possible to create time series plots in SWMM. For 

this, choose Report -> Graph -> Time Series from the Main Menu. It is also possible to create profile 

scatter plots or profile plots of the sewer system. Profile plots are particularly useful when 

illustrating node flooding (example of a profile plot in Figure 7). Instructions on how to utilize 

SWMM’s graph tools see the SWMM’s user manual (Rossman, 2015), Chapter 9. 

 



14 
 

Figure 7. A profile plot of the sewer system at the time of the worst flooding based on the results in Fig. 6. Instructions for 
creating a profile plot in the SWMM’s user manual (Rossman, 2015), Section 9.5. 
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PART 2: MODELLING LOW IMPACT DEVELOPMENT (LID) SYSTEMS  
Low Impact Development (LID) systems refer to small-scale decentralized urban runoff management 

units of which the primary purpose is to reduce runoff volumes, flow rates and pollutant loads by 

mimicking natural catchment processes. LID systems reduce runoff by decreasing the amount of 

impervious surfaces, by increasing infiltration and evaporation, and by delaying runoff before 

conveying it to the receiving water bodies or drainage systems. In SWMM, several LID options are 

available, including a bioretention cell, a rain garden, a green roof, a rain barrel, a permeable 

pavement, an infiltration trench, a vegetative swale and a rooftop disconnection.  

Creating and simulating LID systems in SWMM includes three phases: 

• Phase 1: Create a scale-independent LID unit using the LID Editor (Project -> Hydrology -> LID 

Controls). 

• Phase 2: Add a LID unit to a subcatchment with appropriate sizing (select a subcatchment by 

clicking the Map Window or from the Project panel -> Hydrology -> Subcatchments -> select a 

subcatchment, select LID Controls from the Subcatchment Editor).   

• Phase 3: Run the LID model with rainfall data, interpret the runoff results. 

An example model file for the LID modelling, Urban_hydrology_example_LID.inp, can be downloaded 

from the MyCourses/Assigments-page.  

DETAILS OF THE BIO-RETENTION CELL EXAMPLE 
In SWMM, a typical bioretention cell is conceptualized by a number of horizontal layers (Figure 8). In 

the following, the bioretention cell is used as an example of how to add LID units to a SWMM model. 

Example parameterizations for a green roof and a permeable pavement are also included. For LID 

techniques not discussed here, example parameter values can be found in the SWMM’s Water 

Quality Reference Manual (Rossman & Huber, 2016b). The bioretention cell is the most complex LID 

unit in SWMM in terms of its structure and sizing. Other LID units are more or less simplifications or 

modifications of the same basic components as included in a bioretention cell. For instance, LID units 

share similar features such as soil layers and storage layers with underdrains. 

 

Figure 8. An illustration of a typical bioretention cell, adopted from the SWMM’s Water Quality Reference Manual 
(Rossman & Huber, 2016b). 
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PHASE 1: USING THE LID EDITOR TO CREATE A LID UNIT (BIO-RETENTION CELL) 

The first phase in LID design is to create scale-independent LID units. 

Our example bioretention unit has a total depth of 1200 mm, consisting of a 700 mm soil layer with 

a berm height of 200 mm allowing some ponding to occur at the top of the structure. Underneath 

the soil layer there is a 300 mm gravel storage layer provided with an underdrain. The hydraulic 

conductivity of the underlying soil is rather moderate, 4.21 mm/h (set as loam), hence, an 

underdrain is used. It is noteworthy that in cold climatic conditions, the use of underdrain is always 

recommended in order to enhance wintertime operation.  

  

 

From the Project panel:  

➔ select Hydrology -> LID Controls 

If you want to add a new LID unit: 

➔ press  from LID Controls menu to add a new 

Object 

in LID Control Editor, fill in a name for a new LID unit, 

select the LID type, and fill in the required parameter 

values. The name of the LID unit in the template file 

(Urban_hydrology_ example_LID.inp) is 

Example_Bioretention. 

➔ In LID Control Editor, parameter values are given 

separately for each LID layer on Surface/Soil/ 

Storage/Underdrain -pages. Screen shots of the 

different LID Control Editor windows with example 

parameter values for a bioretention cell are shown 

on the following p. 17-18. 

  

If you want to modify an existing LID unit: 

➔ select the LID from the LID Controls list of existing LID 

units and press  
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Vegetation is an essential part of a bioretention system, and in the current example it reduces the available 

space for ponding by 15% (Vegetation Volume Fraction 0.15). 

   

The soil properties of the soil layer correspond to a typical engineered growth media for bioretention systems: 

85% sand, 5% clay and 5% organic matter. Typical properties for this soil are given in Table 6-3 in the SWMM 

WQ manual: Porosity of 0.52, Field Capacity of 0.15, Wilting Point of 0.08, saturated hydraulic Conductivity of 

119 mm/h, Suction Head of 48.3 mm/h.  
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Seepage rate corresponds to the hydraulic conductivity of the surrounding soil. If there is an impermeable 

liner at the bottom of the structure to prevent infiltration to the native soil (sometimes needed e.g. to prevent 

the pollution of the surrounding soil and groundwater), set Seepage Rate as 0.  

 

The simplest method of estimating the drain properties is to set Flow Exponent to 0.5 and to use the equation 

2D0.5/T to determine Flow Coefficient. D is the distance from the drain to the surface plus ponding depth (in 

mm) and T is the time in hours to drain (12 h). Hence, the flow coefficient for the current example is 2 * (200 

mm + 700 mm + 300 mm – 150 mm)0.5/12 h = 5.4 mm/h. We can provide additional storage space at the 

bottom of the storage layer by adjusting the drain’s offset height. With 0 mm offset height, the underdrain is 

located at the bottom of the storage layer. For more information about the drain properties, click the Drain 

Advisor link. 
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PHASE 2: ADDING A LID UNIT TO A SUBCATCHMENT (BIO-RETENTION CELL) 
After creating scale-independent LID units, the next phase is to assign these units to a 

subcatchment with an appropriate sizing. 

STEP 1. Left-click a subcathment’s symbol (a small square) on the map window or select the 

subcatchment’s name from the list of subcatchments from the Subcatchments menu (Subcatchment 

s266). Press  to open the Subcatchment Editor. 

  

 

Left-click the small square to select 

a subcathment or… 

… or pick a subcatchment from the 

list of subcathments 
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STEP 2. Left-click the LID Controls value column to open the LID Controls for Subcatchment editor. 

  

 

STEP 3. Left-click Add to open the LID Usage Editor. 
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STEP 4. Select the predetermined LID unit from the LID Control Name list. 

STEP 5. Set the size of LID unit using the LID Usage Editor: 

➔ Area of Each Unit: Add the surface area of the LID unit in m2. SWMM will automatically update 

% of Subcatchment Occupied. For a bioretention cell, surface area of at least 2% of the total 

catchment area is recommended. In our example, 23 m2 bioretention cell covers approximately 

3% of the total catchment area.  

➔ For a permeable pavement or a green roof, LID Occupies Full Subcatchment can be selected (if 

the LID covers the subcatchment area completely): in this case, SWMM will automatically set 

the area of the unit equal to the total subcatchment area. 

➔ Set % of Impervious Area Treated to 100%, because the bioretention cell is going to capture all 

runoff from the non-LID area of the subcatchment that is completely paved with asphalt. 

➔ In the current example, default values (0) for other parameters can be used. Explanations for all 

parameters in the LID Usage Editor are given in the SWMM’s User Manual on p. 252-253 

(Rossman, 2015). 

As default, any surface overflow (i.e. runoff exceeding the capacity of the LID unit) or underdrain 

flow from the LID unit is sent to the subcatchment’s outlet destination. By selecting Return all 

Outflow to Pervious Area, all runoff from the LID unit is conveyed to the pervious fraction of the 

subcatchment (might be useful in the case of rain barrels). 

How to determine the capacity of the bioretention cell? 

In the current example, the area of the bioretention cell, 23 m2, comprises 3% of the total area of 

the parking lot (Subcatchment s266). Therefore, its Capture Ratio is (1-0.03)/0.03=32.3 (the 

impervious area that contributes runoff to the LID structure divided by the area of the LID itself). The 

total storage volume contained within the bioretention cell is (1-0.15)*200 mm (the ponding storage 

on top minus the vegation fraction) plus (0.52-0.08)*700 mm (soil pore volume) plus 0.5*300 mm 

(gravel storage volume) for a total of 628 mm. Considering the bioretention cell’s capture ratio and 

its surface area, the capacity of the LID unit is 628 mm /(32.3+1) = 18.9 mm for the total catchment 

area. Hence the system should be able to capture storms up to a maximum depth of 18.9 mm.  
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PHASE 3: RUNNING A LID MODEL AND INTERPRETING THE RESULTS 

➢ INTERPRETING LID RESULTS FROM A LONG-TERM CONTINUOUS SIMULATION 
To run a model, set the rainfall data source (a file or a time series), the climate data file (2005 or 

2006) and the simulation options as described earlier in the Part 1 of this document. Also the results 

are obtained using the same tools as earlier (select Report from the Main Menu). In the following, 

we will take a look at the results for all LID units located in the template file: the bioretention cell at 

a parking lot (Subcatchment s266), a permeable pavement at a parking lot (Subcatchment 265) and a 

green roof in Subcatchment s113. The locations of the LID units are illustrated in Figure 9 using the 

LID Usage theme. The LID subcatchments are directly connected to the sewer system: the junction 

j40 is the closest node in the sewer system that collects runoff from all of these subcatchments.  

 

Figure 9. The locations of the LID units when using the LID Usage map theme (themes can be selected from the Map panel). 
The grey areas show the locations of the green roof and permeable pavement, because these LIDs cover the whole 
subcatchment area. The subcatchment with a bioretention cell is orange, because the bioretention cell covers only 3% of the 
subcatchment area. The dotted lines show the connections between the subcatchments and the sewer nodes. 

After running the model using the rainfall data of the summer 2006 (storms2006.dat), the water 

balance components for the LID subcatchments can be seen from the Summary Report (select 

Report -> Summary). Based on the summary results, the subcatchment s265 produced no runoff 

during the three-month period because of the permeable pavement (Figure 10). In fact, it lost 60.17 

mm as evaporation. The amount of evaporation exceeds the amount of precipitation (52.4 mm), 

because the subcatchment received 8.5 mm of surface runoff from neighbouring subcatchments 

(Total Runon). The subcatchment s266 with a bioretention cell produces 1.6 mm of runoff, which is 

still only 3% of the total precipitation. For comparison, the subcatchment summary reports for the 

template file without LID units were shown earlier in  Figure 5: without LID units, the total runoff for 

the subcatchments S265 and s266 were 41.0 mm and 33.7 mm, respectively.  
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Figure 10. An extract of the summary results (Report -> Summary) for subcatchment runoff (the template file 
Urban_hydrology_example_LID.inp) when using the 2-min rainfall data for the summer 2006. 

The summary results can also be obtained for a single LID structure by selecting LID Performance 

from the Topic list in the Summary Results window (Figure 11). In Figure 11, the total inflow equals 

the precipitation amount only for the green roof, which receives only the rainfall falling on the roof 

surface. Obviously, no infiltration can occur from the green roof (unless the roof leaks), therefore it 

can only reduce runoff through evapotranspiration.  The total inflow is the largest for the 

bioretention cell, because it receives runoff from a much larger area than its own surface area. None 

of the LID units produced surface outflow showing that the capacity of the LID systems was large 

enough to capture all rainfall and runoff input during the summer 2006 conditions. Only the 

bioretention cell produced runoff through its underdrain to the sewer system. 

The chosen structure of the LID unit may have significant impacts on the simulation results. Figure 

12 shows how the results would change if the permeable pavement had no soil layer on top of the 

storage layer (the depth of the soil layer were set as 0 mm). In this case, the permeable pavement 

located in the subcatchment s265 would not produce any runoff to the sewer system, however, 

most runoff was reduced via infiltration and not through evaporation as was shown in Figure 11. 

 
Figure 11. The summary results for LID units alone for the summer 2006. 

 
Figure 12. The LID-specific summary results for permeable pavement without soil layer.
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➢ INTERPRETING LID RESULTS FROM AN EVENT-SCALE DESIGN STORM SIMULATION 
So far the examples of the results have only dealt with the long-term continuous simulations. 

However, comparisons using the design storm time series are important as the drainage design is 

often based on these events alone. 

To run a simulation with a time series, change 

the source of rainfall data as was described in 

the Part 1 of this document: from the Project 

panel, select Hydrology -> Rain Gages and 

press  to open the Rain Gage Editor. 

Check the following settings: 

- Rain Format: VOLUME 

- Time Interval: 00:02:00 

- Data Source: TIMESERIES.  

- Series Name: in the Figure on the 

right, once in every 5-years occurring 

design storm (5-yr_design_storm) is 

selected.  

Close the window. 

 

Before running a simulation, set the simulation time period using the Simulation Options Editor (see 

the figures below): from the Project panel, select Options -> Date and press . Set the duration of 

the analysis by changing the End Analysis on date to 06/02/2006. Also check the Time Steps page: 

set 2 minutes as the Reporting time step and 5 seconds as Wet Weather and Routing time steps. 

Press ok to close the dialog. Run the model by selecting   symbol from the Main Toolbar. 
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Figure 13 and Figure 14 illustrate the Summary results reports (select Report -> Summary from the 

Main Menu) for flow rates (Node Inflow selected as topic that reports flow rates in l/s for a particular 

node) in the junction j40 that collects runoff from all of the three LID units in the LID model. The 

peak flow rate in the junction j40 is 12.1 l/s for the LID model (Figure 13) whereas the peak flow rate 

for the traditional catchment without LID is more than double, 47.8 l/s (Figure 14). Hence, the LID 

units enabled a notable reduction in the peak flow rate during the 5-year design storm event. 

However, because the LID units only cover a rather small area in comparison to the total catchment 

area, there is no difference in the peak flow rate (436.5 l/s) at the catchment outlet (Node o1) with 

or without LID units. 

Figure 13. An extract of the Summary Results for Node Inflow when using 5-year design storm time series as rainfall data in 
the LID model. 

Figure 14. An extract of the Summary Results for Node Inflow when using 5-year design storm time series as rainfall data in 
the template model without LIDs.. 

In Figure 15 and Figure 16, time series plots for the 5-year design storm are shown for the junction 

j40. To obtain these graphs in SWMM, select Report -> Graph -> Time Series from the Main Menu, 

add Node j40 as the Time series and Total Inflow as the variable. 
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Figure 15. A time series plot for the 5-year design storm at the junction j40 without LID units.  

 

Figure 16. A time series plot for the 5-year design storm at the junction j40 with LID units. 
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EXAMPLE PARAMETER VALUES FOR SELECTED LID UNITS  

➢ GREEN ROOF 
Template file: Urban_hydrology_example_LID.inp 

LID object name in the LID Editor: Example_GreenRoof 

Location: Subcatchment s113 

Parameter values for green roof were adopted from a Finnish green roof study (Krebs et al., 2015): 

Krebs, G., Kuoppamäki, K., Kokkonen, T., Koivusalo, H. 2016. Simulation of green roof test bed runoff. 

Hydrological Processes, 30, 250-262. 
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In the template file Urban_hydrology_example_LID.inp, the LID unit Example_GreenRoof is assigned to 

Subcatchment s113. When using LID Usage Editor, select LID Occupies Full Subcatchment (the green roof 

covers the whole roof) and adjust Surface Width per Unit equal to the Width value of the subcatchment (in 

this case the width of Subcatchment s113): you can check it by viewing the Subcathment Editor window, the 9th 

row from the top (Width). The Width applies to LID units that use overland flow to convey any excess surface 

runoff away from the LID unit (green roofs, permeable pavements, infiltration trenches and swales). It can be 

set 0 for other LID units that simply spill excess runoff over their berms (bioretention cells, rain gardens, rain 

barrels).  
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➢ PERMEABLE PAVEMENT 
Model file: Urban_hydrology_example_LID.inp 

LID object name in the LID Editor: Example_PermeableP 

Location: Subcatchment s265 

 

Set Surface Slope equal to the slope of the subcatchment. You can check it by viewing the Subcathment Editor 

window, the 10th row from the top (% Slope). 

  

Note: It is useful to test different values for the pavement permeability. The permeability (360 mm/h) is a 

rather conservative value for permeability and much less than the values often reported in the SWMM 

manuals and literature abroad. In Finland, a design value of only 72 mm/h has been proposed (Kling, et al. 

2015), which according to literature presents a clogged state.       

 (Kling, T., Holt, E., Kivikoski, H., Korkealaakso, J., Kuosa, H., Loimula, K., Niemeläinen, E., Törnqvist J. 

2015. Vettä läpäisevät päällysteet. Käsikirja suunnitteluun, rakentamiseen ja ylläpitoon, in Finnish).  
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In permeable pavement, the Soil layer is optional. In the current example, a soil layer with a depth of 400 mm 

was included in order to promote better pollutant retention. Thickness of the soil layer can be set as 0 mm to 

ignore it. Here the soil layer parameters represent sand, adopted from the SWMM’s Hydrology Reference 

Manual (Rossman and Huber, 2016a), p.151. 

  

If the clogging of the system over time is included, instructions on how to determine the clogging factor are 

given in the SWMM 5.1 User’s Manual on p. 247 (Rossman, 2015). Set Seepage Rate equal to the conductivity 

of the surrounding soil, if there is no need for preventing infiltration from the system to the soil below. 
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The drain properties were earlier described for bioretention cell on p. 18 and the same rules apply for any 

Drain layer. For permeable pavement in the current example, a time to drain of 2 h was used. Additional 

storage space at the bottom of the storage layer was provided with the 150 mm Offset Height. For more 

information about the drain properties, click the Drain Advisor link in the LID Control Editor. 

 

In the template file Urban_hydrology_example_LID.inp, the LID unit Example_PermeableP is assigned to 

Subcatchment s265. When using the LID Usage Editor, select LID Occupies Full Subcatchment (the permeable 

pavement covers the whole asphalt surface) and adjust Surface Width per Unit equal to Width value of the 

subcatchment (in this case the width of Subcatchment s265). This parameter applies to LID units that use 

overland flow to convey any excess surface runoff off of the LID unit (green roofs, permeable pavements, 

infiltration trenches and swales). It can be set 0 for other LID units that simply spill excess runoff over their 

berms (bioretention cells, rain gardens, rain barrels). 
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PART 3: CHECK LIST FOR RUNNING A SIMULATION 
 

STEP 1: Investigate the catchment area for suitable locations for different types of LIDs: green roofs 

for roofs, bioretention cells and permeable pavements for asphalt surfaces. You can try other LID 

techniques as well. 

STEP 2: Create a LID unit using the LID Editor. 

STEP 3: Add the LID unit to a subcatchment using the LID Usage Editor. 

STEP 4: Add rainfall data: a data file or a time series, time interval 2 or 10 minutes? 

STEP 5: Check the climate data file, the year 2005 or 2006? 

STEP 6: Check the simulation options: the dates of the simulation period (3 months for long-term 

simulation, 2 days for a design storm), the time steps (Reporting, Wet Weather, Routing). 

STEP 7: Run a simulation. 

STEP 8: Interpret the results. 


