
5. M1plus- Stoll pattern Software for knitwear : importing an image for 
Intarsia

-In Intarsia there is only one active yarn color and yarn carrier in 
each area, this means that the limitation of the number of color 
areas/carriers is 30 (2 are needed for the start).
Your image needs to be suitable for intarsia, prepare it before-
hand. 

Example: Red dot on blue background
-If you would like to knit a red dot on blue ground, each area 
needs it own yarn carrier. Although areas 1&3 would be knitted 
with the same yarn, separate carriers need to be set.

-Another color should be added to the image, to section 3, in order 
to be able to set a different yarn carrier for that area. 

Example 5.1: Vertical Intarsia stripes with 6 
colors, single knit

1.Open M1plus software and make a new pattern according to 
previous instructions. The pattern size should be identical to your 
picture. Select the desired start. Generate Design Pattern.

2. Go to File ->Import -> Picture as Pattern Element...
“Step 1:Picture Selection”- window will open. Go to Load... -> 
select you picture file. The width, height and number of colors in 
your design will be displayed. Adjust the dimensions of the picture 
if needed. Select Presentation: All needles.

Yarn carrier 1

Yarn carrier 2

Yarn carrier 3 with the same yarn than 1

3. Next > to go to Step2: Color Selection-window, and 
reduce the colors if needed by adding the number of colors you 
would like to have and selecting Color 
reduction. Under Pattern, select Structure/Intarsia.
Select Complete. 

4. Your picture will now appear as selected item, place it to its 
correct place in left corner after the start with the left click of the 
mouse. Remove the selection with ESC. 

5. Set the Yarn Field (optional step, can be also completed later). 
Drag the Yarn carriers to their places. In this case the machine has 
set 3 carriers to left and 3 to right, according to the colors closest 
to left edge and closest to right edge of the piece. 



7. Check the fabric view. When you click with the right mouse 
click and select view from back, you can see how the yarns 
are transported across the design in the beginning. Close the 
fabric view. 

8. Start processing. Save the pattern. 

9. Run Sintral Check.

You could also add different structures to your intarsia 
pattern, by for example drawing with different stitch notations 
or adding some modules from the library or create your own 
modules.  

6. Select-> Expanding entire pattern. If you have too many 
yarn colors or impossible areas for intarsia, the program will 
show you an error. 
On the left picture you can see the tuck stitches created in each 
boarder area, in order for the yarn areas to be linked to each 
other.  

6. Saving your own modules:

1. Draw one repeat of pattern with desired stitch actions. 
Select a pattern area in the “Symbol View [Basic]”.

2. Go to “Module” -> “Generate from Selection” 
->“Module “ menu. Or click on the             icon in the 
“Default” toolbar.

The “Module Editor” appears with the contents of the 
selection. Check fabric view from View- “Open new Fabric 
View”. Close the fabric view. 

3. Close the Module Editor with  the X. ->The new 
module will be saved as Local module in the “Modules” 
toolbar under “Local Modules”.

4. To save a local module in the data base: Select a local 
module in the “Modules” toolbar under local modules.
Go to context menu with the right mouse button and 
select “Save to database”.

-> The module is saved to the “New Modules” module 
group of the “Module explorer of database”.Modules 
saved in the data base are available for further patterns. 
The L marking  (for local module) is no longer present.

Module Editor, Fabric viewLocal Modules before saving

Module Editor, Technical View



7. M1plus- Stoll pattern Software for knitwear : jacquard intarsia

1.Open M1plus software and make a new pattern according to previ-
ous instructions. Select the desired start. Generate Design Pattern.

2. Go to File ->Import -> Picture as Pattern Element...
“Step 1:Picture Selection”- window will open. Go to Load... -> select 
you picture file for jacquard intarsia. The width, height and number 
of colors in your design will be displayed. Adjust the dimensions 
of the picture if needed. Your image can be smaller than your file. 
Select Presentation: All needles.

3. Select Next > to go to Step2: Color Selection-window, and 
reduce the colors if needed by adding the number of colors you 
would like to have and selecting Color reduction. Under Pattern, 
select Structure/Intarsia.

4. Select Complete and place the image to the wanted place in your 
file. Remove unnecessery colours around your design by filling them 
with surrounding colour (for example with Magic Wand). 

5. Select your placement design. You can do this for example by 
selecting the colors around the design and all the starting rows with 
magig wand. To select several colour areas keep ctrl-button pressed. 
Then go to Selection -> Invert Selection. 

6. Go to Edit -> Generate or Edit Jacquard...

7. In the Jacquards-window, make the desired settings according to 
previous instructions. Select the desired back for the jacquard from
 the list under Stoll-file. 

8. Select Apply. Select OK.  

9. Finish the prosessing steps (optional Yarn Field, Expanding 
Pattern, Start Prosessing, save the pattern, Run Sintral 
Check.

 
 

It is possible to combine areas of jacuqard and intarsia. If you want 
to have multicoloured motif surrounded by single colour with 
single yarn, use jacuqard in the multicolored motif and intarsia 
around it. 

Fabric View from back, Net 1x2

Jacquard and single knit around it



8. Weft inlay with Colour arrangement: single knit with inlay 

1. For the inlay draw or import a picture with different 
colour areas. In this example each colour area will 
represent area where the inlay yarn behaves differently. 
The base structure (e.g. single knit) could also be differ-
ent in ecah colour area).
In this example the picture has 3 colours. To import 
picture go to File-> Import picture as pattern element.

2. After the picture is imported, select all the rows with 
the image (not the start) from pattern rows and go to
Module-> Generate from Selection-> Color Arrangement
or click          icon. 

3. Properties of: CA-window will open, just clik ok. 
Color Arrangement Editor opens up. You can zoom in 
with + key. In the bottom of the window are the 
“searching colors”, all the colors that are in the selected 
area of your design. On top of the searching colours 
different stitch types and functions can be added. 
The CA reads all the different colours automatically as 
intarsia, and for that reason all the colour are on differ-
ent rows. Now this needs to be altered, as the example 
only has 1 yarn as base doing single knit, not 3 different 
yarns as intarsia. 

4. Take a move-tool 
and drag all the colors with number 1 to the same row, 
and all the colors with number 2 to the same row. 

5. Select the rectangle-tool. Pick a new color and draw it 
in to the rows with 1 and 2.
This is your yarn for the single knit background. 

Stoll ADF machines has a weave-in-device, which is able to add yarns to the knit, without knitting them on the needles. The machine has 2 
special inlay yarn carriers, which are able to accomodate also thicker yarns. The inlay may be used as a visual effect to obtain floats or a 
woven-fabric look, but also to add some functionality, for example reduce the stretch and increase the durability in some areas.
Inlay may be added on top of different knit strcutures, both single and double bed structures.  



6. Pick front stitch with transfer needle action and draw 
it in the green lines. 
 If you leave the drawn-in green color squares empty, the 
program will take the needle action from the original 
image in the symbol view. If you draw needle actions in 
colour arrangement, those will overwrite the settings of 
the symbol view background. 

7. Now the width of the different pattern areas need to 
be adjusted for the planned inlay structures. For the blue 
searching color there will be inlay structure which goes 
in and over 1stitch and does the opposite on the next 
row (kind of plain weave structure). For this the width of 
the area needs to be 2 stitches. Select the vertical column 
3 where the blue searching color is and press Insert-key 
in your keyboard. 

8. Insert columns-window opens up. Click selection and 
set numer:1 as we only need to add 1 more stitch. Click 
ok. Now you have 2 stitches in the blue area. 

9. Now draw in the inlay yarn. Take a new color and 
draw it in the 3rd rows after the green yarn. 

10. Open Color Arrangement-toolbar from View-> 
Toolbars-> Color Arrangement. Take a number 1 and set 
it next to the first brown inlay row. Take numer 2 and set  
it next to the second brown inlay row. 
After that take pink square “additional row”-tool from 
the CA-toolbar and paint the added numbers with the 
pink color.
This means that the inlay yarn is added always on top of 
the single knit row when knitting. 

11. Now draw in the actions for the inlay yarn. 
In the blue area it goes under 1 and over 1. When it’s 
behind the single knit, pick a float-tool and place it on 
the left brown square in blue area. For the right square, 
pick a “Inlay thread/transfer to the front with float”tool.
Pick a transfer to the rear green arrow-tool and place 
it under the Inlay Thread-transfer. This means that the 
front stitch will be temporarily transfered to the back 
and the inlay float in front of it. Do the same but in 
opposite order for the inlay row number 2.

12.  Now draw the structures for the inlay yarn for the 
other colors. In the example in the white area the inlay 
yarn will go over and under 3 stitches. Select the column 
with white searching color, press insert-key and add 5 
more stitches. Now as before, draw 3 stitches with float 
and 3 stitches with Inlay Thread-transfer and green 
transfer-arrow. Do the opposite for the second inlay row. 



14. Change the red repeat marks to blue/black from 
the Color Arrangement toolbar. This means that the re-
peat will be counted from the edge of the whole design, 
and it will appear in order in the design. If you use the 
red repeat-mark, the repeat will start again from the 
edge of each color area in the design.

15. Check that the direction of the carriage is correct
for each row of the design. The 3 first rows with 
reference row number need to go from right to left and
the last three rows with reference row number 2, from 
right to left, as in the picture. If you need to change the 
directions, click on top of the carriege direction with right 
mouse click and select the right direction. Then click on 
top of the row where you would like to place it.

16. The first and last 3 rows, should also be grouped 
to get the correct fabric view. The rows should have the 
same pattern row number like in the picture. If this is not 
the case, select the first 3 rows and press F8, then select 
the last 3 rows and press F8.

17. 2 more settings need to be done in CA.
From the control column selection, open select colums,
Presser foor-setting. Click with the right mouse un-
derneath the presser foor rows and select “Weft Yarn 
presser foor ON” and click on the inlay rows. Press Esc.

18. From the same control colum selection, select “plat-
ing-offset of yarn carrier (YPI). Next to the inlay rows, 
click with right mouse and select Q inlay Thread from the 
menu. Place the Q next to the inlay rows.  

13. Draw in the structures for the inlay for the 
last color area in the design. In this example, in 
the greay area the inlay yarn will go over and 
under 6 stitches in the design. So as before, 
add columns with insert key, in this case add 
11 colums. Draw in the structures like before. 
Add also reference row number 1 and 2 to 
the transfer rows in the CA, and add the pink 
“additional row”-color to those as well. 



19. The CA is ready. Close the CA window, and click YES 
to apply the modifications. 

20. Click on control column selection, and select Color 
Arrangement. Now you can see the color arrangement 
drawn in for all the rows you selected in the beginning.
The wide and narrow green markings mean the size of 
the repeat, every wider marking is the beginning of 1 
repeat, as in this example the repeat is only 2 rows.  

21. For modifications, the CA can be found Under local 
color arrangements menu, on the top left corner of the 
program.

22. Next you may set up the Yarn Field, or you can skip 
this and leave it to Anna in Otaniemi. If you set the 
Yarn Field, the inlay yarn needs to be pleaced either to 
yarn carrier 6 or 9, as those are the special inlay yarn 
carriers. 

23. Go to Pattern Paremeters-menu ->Configuration
->Knitting areas->Special Fabric Pieces, click Use yarn 
color: add 205. Click apply. Cick OK. This prevents the 
last protections rows of the design to be knitted with the 
inlay yarn, which is usually thick and knitting it in may 
cause problems. 

24. To finish the design, go to Expanding entire pattern. 
Now the technique setted with CA will appear in the 
design. Press F for the fabric view.

25. Close the fabric view and and go back to load basic 
pattern for modifications, or finish the pattern by clicking 
“start processing”. Save the file. Run Sintral Check.  


