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ABOUT 
FLUIDIT WATER 
SOFTWARE & 
LICENSES



FLUIDIT WATER
• Is a hydraulic network modelling and analysis software from Finland

• Core simulator is an improved version of EPANET 2.2
• → EPANET manual is a good source of basic information

• Fluidit Water model files have postfix ”.fwat”
• ”Simple independent files” – can be copied, renamed, deleted, etc…
• All model information (network, results, etc.) is stored in the ”.fwat” –file, there

is no external database
• Some background maps and elevation model are fetched from internet or from

external files

• Technical information:
• Runs on Netbeans Platform
• Written in Kotlin (Java-based language)
• Also uses Python and JavaScript as scripting languages
• (but you dont need to know these to use the software)
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INSTALLATION

• Requires Java JRE 8, 9 or 10 (64-bit)

• Unzip software package, no separate installation
• Do NOT use folder “Program Files” – might run into user right problems
• At Fluidit we use “C:\prog\”

• To start the software: \bin\water64.exe

• Fluidit Water uses a temporary folder: C:\Users\YourUsername\.water\dev
• This can also be accessed via: Tools → Open Model Temporary Directory (→)

• Program version 1.0 (and soon 1.1) is available as Windows installers, which
make shortcuts to desktop and start menu 

• New versions of the software are available frequently
• Please check support –service regularly
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LICENSES

• HueWACO has a test license for now, which is valid until the end of March
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SUPPORT

Support web pages: https://support.fluidit.fi

• Wiki / manual

• Latest versions of the software

• HueWACO has one username/password –set

Support: support@fluidit.fi
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SETTING UP & 
NAVIGATING IN 
FLUIDIT WATER
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GENERAL VIEW

Model Properties (calculation properties, CRS, etc…)

Drawing States: 
• Control what and how components are shown on Map View
• Drawing Order
• Colors and Sizes (possibly based on results)
• Filters, Numerical Labels, etc…

Background Layers:
• Online background maps (street maps, aerial, etc.)
• Add files as background image (for example .dxf or .shp)
• Raster layers calculated from results
• Manage layer order 

Scenarios: 
• “Treelike” structure of the model

Elevation Model

Schematics – predefined chart, figures and maps to present 
results 

Result window following your selection on 
Map View

Properties of the selected component

Modeling tools: Add Components

Python Code – optional, enable complex control systems
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CUSTOMIZE YOUR VIEW
• Manage windows

• Move around by dragging from the tab 
• Close and minimize are found as icons
• Additional options can be accessed with a right-click on the tab (→)

• Float makes a new separate window, which can be taken to a second screen for example

• New windows can be opened via Windows –menu. Common ones include:
• Properties – selected component (or scenario, drawing state, etc.) properties
• Results – visualize results from selected components as time series
• Statistics on Selected Components
• Profile View

• Tooltip – what is shown in Map View when cursor is above a component – can be customized
• Tools → Options →Map View → Tooltips

• General Appearance of the software can also be modified
• Tools → Options → Appearance → Look and Feel
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NAVIGATING MAP VIEW

• Move around: middle mouse button or arrow keys

• Zoom: mouse roll or ”+” ja ”-” keys

• ESC key activates select tool 

• Select components by clicking or dragging over an 
area

• +CTRL adds to current selection

• +SHIFT+CTRL removes from current selection

• CTRL down → shows elevation in lower right corner

• ALT down → can be used to measure distances

• ALT + SHIFT down → can be used measure area
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ACTIVATE DRAWING STATES
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• Activate a Drawing State
• By double click

• Or right click → Activate

• A Drawing State defines what 
components are shown and in what 
colors & sizes

• A Drawing State also has a specific set 
of Background Layers visible

• Drawing States are model-specific, but 
can be imported from other models

• More on Drawing States later…
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COMPONENT LISTS
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All components of the model can be 
seen as a list from Model -menu 

Lists can be used for example to:
• Select components
• Arrange components by any 

property or result
• Edit several components at once
• Copy-Paste (into Excel for example)
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BASIC 
FEATURES: 
MODEL 
PROPERTIES & 
SIMULATION



MODEL PROPERTIES
• Coordinate Reference System (CRS)

• Select from the list, you can type to use search
• This is the model general CRS. Import material and background layers can be given different CRS and 

the program will make the transformation.

• Friction Model – we recommend using Darcy-Weisbach
• Units – we strongly recommend using standard l/s

• Simulation Start Time
• Simulation End Time
• Report Results Start

• Report Step
• Hydraulic Time Step

• More about simulation settings can be found in the EPANET manual
• …and we can also talk more about advanced setting later in this training
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SIMULATION

• From menu “Simulate” → “Simulate” or shortcut F5 key

• Simulator writes a report on the progress of the 
simulation during calculation. This report can be found 
“Simulate” → “Simulation Report” or shortcut F6 key
• If simulation fails, this is the main way to find out why 
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MORE BASIC 
FEATURES: 
TOOLS & 
WINDOWS 



MAP VIEW: RIGHT MOUSE BUTTON

• Right mouse click anywhere opens up a menu, which
is dependent on the location and selection

• Common uses:
• Google Street View

• Split Link / Join Here

• Select components in Zone/Downstream/Upstream

• Connect Selected Link/Demand here

• +++
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STATISTICS ON SELECTED 
COMPONENTS
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This window shows statistical information about 
components selected in Map View. 

Common uses are for example:
• Number of components selected

• Total length of selected links

• Highest and lowest pressures or unit head losses

• +++

Alt + mouse click on top of the results from 
individual components (for example highest 
maximum flow) selects the component
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RESULT WINDOWS
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Can be used to lock to current selection – window does not 
update with Map View selection anymore

Instead of individual component results, result -
window can be set to show statistical values

Some example uses:
• ”Sum” of the result ”Demand” – total water taken

out of the network from selected nodes
• ”Avg. + Extremes” of the result ”Pressure” – lowest

and highest pressure in the selected nodes
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FIND TOOL – CTRL + F
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• Can be used to find components with
expressions from simple to very complex

• For example: 
• Junction-1
• z > 20
• connectionsList.size() == 2 && 

connectionsList[0].material = 
connectionsList[1].material

• Tool uses JavaScript
• Example expressions can be found in Wiki
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MATERIAL LIBRARY
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• Model→Materials
• Add new materials
• Modify or delete old materials

• Materials can be imported from another model (File→ Import Features to Model)

• Tools →Material Packs
• There is no full ”Vietnamese Material Pack” ready
• We have started to make one, we should finish it together

• Important material features:
• Name
• Darcy-Weisbach roughness

• (or Hazen-Williams)

• Inner Diameter (mm)
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BACKGROUND 
LAYERS & 
ELEVATION 
MODEL



BACKGROUND LAYERS
• In model tree on the left

• Mouse right button on “Background Layers” adds layers
• Double mouse click: on/off
• Top Layer is shown on top

• Right mouse button “move up/down” or by drag

• Selection of street maps, aerial imagery, etc.

• Files / network maps / own maps:
• Add DXF Layer
• Add Raster Layer → Raster layers: for example georeferenced images
• Add File Layer → Vector Layers: for example .shp
• Add WMS Layer →Map servers: URL and username/password, select layers

• Calculated Layers from model properties/results:
• Add Elevation Layer
• (Add Node Raster Layer → general node result visualization raster →more later, if we have time)
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ELEVATION MODEL (FROM FILE)
• ”Basic Elevation Model” from Google DEM

• (quality of the elevation data varies around the world, some fixes to handle the material
better is currently under work at Fluidit) 

• ”Grid DEM” from File: ”.tif” raster files

• Possible to have several elevation models

• Fluidit Water first tries the one on top 

• → if no data, then tries the next, etc.

• Fluidit Water also supports Virtual Elevation Models – elevation layers
calculated from other elevation models

• For example constant ”– 1 meter from Basic Elevation Model”

• Rarely used in Water Distribution (more in Sewer)…
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ELEVATION MODEL IN HUEWACO
MODEL

• Fluidit made a conversion to .tif (in QGIS)

• Grid DEM in HueWACO model refers to a file
”Elevation\elevation3405.tif” → keep the folder with the file
in the same directory as the model

• Or update the path to the elevation file
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SOME GENERAL 
TIPS



GENERAL TIPS

• Save often 
• Every now and then make a new copy (Save As…)
• Fluidit Water automatically makes a back-up save of the old model file (“.fwat.bak”) to the same directory 

when you save replacing the old version

• Many problems can be solved by simply closing the software and re-opening

• Fluidit Water writes an internal log
• Windows → IDE Log
• If you have some problems, this can help to find out why
• Can be copy-pasted and sent to Fluidit Support
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PHYSICAL 
COMPONENTS



PHYSICAL COMPONENTS
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• Links
• Pipes

• Valves

• Pumps

• Pump Batteries

• Nodes
• Junction

• Reservoir

• Tank

• Demand
• Technically not a “node” as it is 

not part of the network
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LINKS



PIPE
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• Basic hydraulic parameters:
• Length [m] (automatically calculated)

• Material or 

• Diameter [mm] and Roughness [mm]

• (Minor Loss Coefficient)

• Initial Status
• Open – free flow

• Closed – no flow

• Check Valve – one-way flow (from Start Node to End Node)
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VALVE
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• Used to model control valves, gate valves (fully open/closed) can be 
modeled with closed pipes

• Type
• Flow Control – reduces flow to given setting

• Pressure Reducing – reduces pressure to given setting

• + 4 others…

• Setting
• Depends on the type

• Flow Control = l/s

• Pressure Control = mwc

• etc…
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PUMPS
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• Used to model pumps running at known speed (rpm)
• Speed (setting) can be changed during simulation

• Pump Definiton
• Q-H –curve

• Efficiency Curve (+ electric motor information)

• Setting
• 1 = pump running at full speed

• 0.5 = pump running at half speed

• etc…
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PUMP BATTERIES
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• Used to model pumping stations with controls – for example 
constant pressure

• Type
• Constant Pressure – keeps the given pressure setting at end node

• Constant Flow – pumps a constant flow through the pump

• Constant Generated Head – adds a constant amount of pressure  

• Setting
• Depends on the type

• Constant Pressure = mwc

• Constant Flow = l/s

• Constant Generated Head = mwc
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NODES



JUNCTIONS
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• Used to model pipe intersections, material changes and points for 
consumers to take water from network

• Elevation
• Usually taken automatically from Elevation Model

• Flow out of Junction
• Consumers are usually modeled with geocoded demands, which attach to junctions

• Leakage can be modeled steady direct demand in junctions

• Or with Emitters – a coefficient taking water out of the junction depending on 
pressure

• Demand
• Can be set directly in the Junction, although usually Geocoded Demands are used

• Demand can also be negative (water into network)
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RESERVOIRS
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• Used to model water sources
• Water enter network from Reservoirs: “new water is created”

• Always keeps a desired (usually constant) Head – by pushing water 
into network or taking water from network
• Reservoir ALWAYS has a Head equal to its Elevation

• → Pressure = 0 (free water surface)
• (Pressure = Head - Elevation)

• Elevation
• Possible also to give a Head Pattern (elevation changes over time)
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TANKS
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• Used to model any water tanks 
• (usually water towers or underground tanks)

• Water can flow in and out, but no new water is created

• Elevation
• Tank bottom elevation – when the tank is empty

• Levels
• Minimum Level – almost always 0

• Maximum Level – at what water level the tank is full

• Initial Level – water level at the start of the simulation

• Area / Diameter / Volume Curve
• Only one of these is given

• Defines the relation between water volume and level in the tank
• For example if 100 m³ of water flow into tank, how much water level rises
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DEMANDS
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• Used to model water consumers 
• Always connect to a Junctions

• → Water leaves the network from Junctions

• Base Demand (l/s) or Daily Demand (m³/d)
• Water taken out of the network by this demand

• Pattern
• How water intake varies during the day

• If Pattern = [None] → steady flow

• Demands are usually imported from CIS / NIS / GIS
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NON-PHYSICAL 
COMPONENTS



NON-PHYSICAL COMPONENTS

2019-03-18 Mika Kuronen

• Patterns
• Describe repetitive changes in a value, usually relative 

to the average value

• Curves
• Describe relation of two variables

• Different types

• Pump Definition
• Combine QH-curves, efficiency curves and motor 

information into a pump

• Chemicals
• Parameters for water quality simulations

Values can be pasted from clipboard 
(from Excel, for example) into Fluidit
Water and the other way around
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PATTERNS
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• Most commonly used to hourly change water taken from the network by demands 
• Water taken out from the network = Base Demand (l/s) * Pattern multiplier for every hour

• Can also be used to change:
• Reservoir Head

• Pump Setting

• Pattern Time Step can be changed in Model Properties
• Time Step = How many seconds every step lasts

• Usually and by default Time Step = 3600 = 1 hour → 24 values to represent one day

• Usually made so, that pattern average equals 1 → pattern does not change total consumption (m³/d) 
• Others can also be used, for example to multiply water demands or for setting/head patterns
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CURVES
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Most common uses include:

• Continuous pump (Q-H, type 3)
• Can be given in 

• A) One operating point (nominal duty point)

• B) Three operating points (a curve is fitted through these three points)

• C) In tabular form (many Q, H –pairs)

• Pump Efficiency

• Volume
• Used for tanks to define volume – water level relations, if tank area is not constant
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PUMP DEFINITIONS
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• Pump Definitions are used to combine different curves and other information into 
pumps
• Q-H –curve, usually “continuous pump, type 3”
• Efficiency curve to represent pumps hydraulic efficiency (optional)
• Electric motor information (usually nominal power and efficiency class)
• Selection if the pump is driven by an inverter (it’s losses are taken into account)

• Inverter is also known as frequency converter or variable speed drive (VSD)

45



ZONES, TAGS

2019-03-18 Mika Kuronen

• Zones can be used to classify components into different zones
• Common zone types are pressure zone and metering zone

• Zone types are created via Model → Zone Types
• Zones are created via Model → Zones

• Zones can be used for example
• To set leakage
• Search components
• Filter components

• Tags can be given all components
• Component can have several tags, separated by a comma
• Their uses are similar to zone: search, filter, etc…
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CHEMICALS
• Common uses:

• Water Age

• Water Source (tracing reservoirs)

• Pollution (contamination) spreading

• Chloride

• Below are chemical properties for:
• Water source modeling

• Water Age modeling
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https://support.fluidit.fi/projects/simulators/wiki/Quality_Simulations
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TOOLS



TOOLS 

• Fluidit Water has a separate tool to assign Demands to their nearest junctions
• Tools → Demands → Update Demand Junctions
• Demands can also be set by hand (select demand → right click on junction → Connect Selected Demand…)
• Demands with “Sticky” = true are not affected by the tool
• Junctions set to “Ignore fo Geocoded” = true are affected by the tool

• Fluidit Water has a tool to update selected point elevations from Elevation Model (DEM)
• Tools → Update Point Elevations
• Updates selected components or if nothing is selected, all components
• Usually elevations come automatically when nodes are created
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LEAKAGE TOOL 
• Fluidit Water has a separate tool for setting leakage

• Tools → Demands → Assign Leaks
• Leakage can be divided to a specific area (selected area, whole system or by zones)
• Leakage is se to junctions of the selected area depending on

• Pressure
• Lengths and diameters of the pipes joining the node

• Can be to set a steady leakage (direct demand) or pressure dependant (emitters)

• There is also a tool to set given demand to selected nodes evenly (Tools → Demands → Assign Demands)
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Select area: selections, zone, etc. Select a pattern for leakage or to 
use emitter

Displays the billed demand of the 
area

Press “Assign”Input field for TOTAL WATER 
CONSUMPTION  (billed + leakage)

https://support.fluidit.fi/projects/simulators/wiki/Assign_leaks
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SCENARIOS



SCENARIOS
• Fluidit Water has a support for scenarios – different versions of the model in the same file

• Scenarios are hierarchical: changes made to parent scenario is inherited to it’s child scenarios, but not the other way 
around
• Components changed in a scenario are marked with “Changed in Scenario” = true, and changes made to this specific component in

it’s parent scenario are no longer inherited 
• New components (no corresponding component in parent scenario) are marked with “New in Scenario” = true
• NOTE: these changes are always compared to it’s direct parent scenario (one above) – not Base Scenario
• NOTE: this information is only updated when scenario is loaded. Active another scenario and return.
• Tip: sorting component tables by these properties (Changed / New in Scenario) is an easy way to locate components modified in

active scenario

• Simulated results can also be compared between scenarios: visualize with “Compare to”
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RESULT 
COLORS & 
SIZES

DRAWING 
STATES



EDITING COLORS & SIZES
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• Model → Edit Result Colors & Sizes

• Color and size definitions can be copied and 
pasted to/from clipboard (for example Excel)

• Color and size definitions can also be imported 
from another model file
• File → Import Features to Model
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DRAWING STATES
• Drawing States

• Each Drawing State has definitions how components are displayed in the map view (if at all)
• Usually component colors (Color Based on) or sizes (Scale Size Based on) are changed depending 

on some simulation result
• …or text / numerical value is added next to components
• Pipe arrows (arrowDirection), several options (for example net flow or maximum velocity)
• Visualizations can be filtered to show only some of the components (for example visualize only 

junctions with very low or high pressure)
• Active (Background Layers) are also saved in every Drawing State
• One component type (for example pipes) can have several visualizators in the same drawing 

state

• Visualization as background layers → Node Raster Layer
• First define colors (Model → Edit Results Color & Sizes)
• Select which results is used (field)
• Common settings: transparency (alpha) ja interpolation on/off (interpolation)
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SCHEMATICS



SCHEMATICS
• Are used to make views of common and essential results

• Schematic figures are defined which component and which result to show

• → updates automatically if scenario is changed or simulation made

• →Makes it possible to see the essential results fast and easy after simulation

• Common schematic tools:
• Map Views
• Figures
• Value View
• Making notes and drawing on top of these: lines, arrows, text…

• Examples of schematics can be found in wiki and in the demo model

• Can be copied to clipboard
• By default as “.svg” –vector images

• Most dynamic things are done via calculation context
• Introduce variables: a result from a component
• Create an expression using the values

Mika Kuronen2019-03-18

                                                                                                        

                              

                                                

          

   

   

   

   

   

   

    

    

    

    

    

    

    

    

                           

                 

                               

                                                                 

   

   

   

   

   

   

   

   

   

    

    

    

    

    

   

   

   

   

   

   

   

https://support.fluidit.fi/projects/simulators/wiki/Schematics
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MODEL FILE 
STRUCTURE



MODEL FILE STRUCTURE
• Fluidit Water –files (.fwat) are zipped archives (.zip)

• Can be unzipped with all common compression software (7zip for example)

• Files are human-readable .xml

• Model can be modified in these .xml –files directly
• Unzip → make changes → zip → change suffix from .zip to .fwat

• Be careful, it is easy to “brake” a model (for example delete a junction that a pipes refers to)

• Example of a single junction named “Junction-4” in the .xml –data:
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IMPORT & 
EXPORT



IMPORT FEATURES

2019-03-18 Mika Kuronen

Can be found in “File” → “Import Features to Model”

Select:
• Do Not Import
• Import Missing – imports the feature if there is no similar feature already set in the model 

• Update Existing – import attributes only to already existing features 

• Update and Import – both of the above

61



IMPORT COMPONENTS
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Can be found in “File” → “Import Components to Model”

Import tools is a generic tools – all supported data types can 
be imported into all model components

Supported file types currently:
• .shp
• GeoJSON
• Excel
• CSV / TSV
• GML
• DXF (no support for importing attributes, only geometry)

Components into model

Coordinate Reference 
System of the import 

material

Method: import new 
components or update 

old

Preview of the import file

Dropdown menu to select what attribute to import 
into what property

Properties are referred by their programmatical 
names.

“geom” refer to component geometry
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EXPORT
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Can be found in “File” → “Export in GIS format”
(or “Export in EPANET format”, but EPANET does not support all Fluidit Water components)

Supported file types currently:
• GeoJSON
• .shp
• Spatialite
• GML

These common GIS-formats can be directly opened in most GIS-
software, for example Qgis or ArcGIS

If you have a selection in Map View tool will export only those selected 
components. If nothing is selected the whole model is exported.

Export functionalities:
• With GeoJSON you can select whether to 

make one GeoJSON with all components or 
different components into separate files

• Select if you want to export properties, 
results, etc. 
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CONTROLS
• Fluidit Water has several ways to control components

• Common steady parameters directly in components (Setting for Pump Battery, etc)

• Support for EPANET Rules and Controls

• Are enough for most networks

• Easy to use and well documented in EPANET manual

• Python –programming language can be used to write scripts

• For complex control systems

• Not part of this basic training, but if needed Fluidit can provide additional material / training

• More about rules and controls can be found in EPANET manual:

• Controls page 143

• Rules page 164

• Example from demo model (→)

• Note: Pump Batteries are controlled as “Valves” in EPANET commands
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COMMON MISTAKES
• Not enough water or too much water is pumped in to a pressure zone

• Happens with flow control – pressure control adjusts to water use

• Can lead to very (unrealistic) high or low pressures – results are not to be trusted

• EPANET is by default a demand dependent calculation engine – all demand will always be fulfilled
• No matter how high or low pressures are required

• Simulation engine will even open closed pipes to fulfill demand

• Changes made to wrong scenario or wrong drawing state
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COMMON PROBLEMS WITH SOFTWARE

• Self-updating windows (Properties, Results, Statistics on Selected Components, etc) are very useful, but can be 
slow when handling large number on components

• To make things go faster, before making any huge selections, close all or some of these windows

• Drawing States with lots of components visible and complex filters etc. can be slow

• To make things go faster, use drawing states with less visible components and no filters etc.

• Some software problems can be solved with a “clean install”
• Delete the content of your Temporary Directory: C:\Users\YourUsername\.water\dev

• Install the software (unzip from package) again
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HYDRANTS

• Usually used to model hydrants or sprinklers
• But can be used to model any water taken from the network

• Important parameters:
• Opening and Closing Time 

• As seconds from the start of the simulation

• Maximum Flow

• Minimum Pressure

• Short instructions also available in Wiki
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ANALYSIS



PUMP BATTERY ANALYSIS

2019-03-18 Mika Kuronen 71


