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IBM SPSS Statistics - Essentials for R: Installation
Instructions for Windows

IBM SPSS Statistics - Essentials for R: Installation Instructions for
Windows
The following instructions are for installing IBM® SPSS® Statistics - Essentials for R on Windows
operating systems.

Overview
IBM SPSS Statistics - Essentials for R provides you with tools you need to start developing custom R
applications for use with IBM SPSS Statistics. It includes the following:
1. The IBM SPSS Statistics - Integration Plug-in for R for IBM SPSS Statistics 23
2. A set of working examples of R applications for IBM SPSS Statistics

Install the IBM SPSS Statistics application
IBM SPSS Statistics - Essentials for R is designed for the following applications:
v IBM SPSS Statistics for Windows
v IBM SPSS Statistics Server for Windows

There are no additional operating system and hardware requirements. The components installed with
IBM SPSS Statistics - Essentials for R work with any valid IBM SPSS Statistics license.

If you have not already done so, follow the instructions provided with the software to install one of the
IBM SPSS Statistics applications on the computer where you will install IBM SPSS Statistics - Essentials
for R. If you are installing IBM SPSS Statistics - Essentials for R on a desktop machine, install IBM SPSS
Statistics 23 on the desktop machine. If you are installing IBM SPSS Statistics - Essentials for R on a
server machine, install IBM SPSS Statistics Server 23 on the server machine.

Download and install R 3.1
Version 23 of IBM SPSS Statistics - Essentials for R requires R version 3.1 (version 3.1.0 is recommended).
Install R on the computer where you will install IBM SPSS Statistics - Essentials for R. It is available from
http://www.r-project.org/. You can also download it directly from ftp://ftp.stat.math.ethz.ch/Software/
CRAN/bin/windows/base/old/.

Download and install IBM SPSS Statistics - Essentials for R
Be sure to use a version of IBM SPSS Statistics - Essentials for R that is compatible with the version of
IBM SPSS Statistics on your machine. Within a major version of IBM SPSS Statistics, such as 23, you must
use a version of IBM SPSS Statistics - Essentials for R that has the same major version. It is not necessary
to uninstall earlier versions of IBM SPSS Statistics - Essentials for R before installing a newer version.

For users who are working in distributed mode (with IBM SPSS Statistics Server) please install IBM SPSS
Statistics - Essentials for R on both the client and server machines.

Download version 23 of IBM SPSS Statistics - Essentials for R, available from the SPSS Community at
http://www.ibm.com/developerworks/spssdevcentral.
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Windows XP
1. Double-click the downloaded file and follow the instructions that appear on the screen.

Windows Vista or later

You must run the installer as administrator:
1. Using Windows Explorer, browse to the folder where you downloaded the file.
2. Right-click the downloaded file and choose Run as Administrator.
3. Follow the instructions that appear on the screen.

Important:

v If you are installing Essentials for R on a computer that does not have internet access and you plan to
use the working R examples included with Essentials for R, then you must obtain any R packages that
are required by those examples and manually install them in R. To determine which R packages are
required for a specific R example, open the Installed Extension Bundles dialog (Utilities > Extension
Bundles > View Installed Extension Bundles) and click the highlighted text in the Summary column for
the associated extension bundle (each R example is installed as an extension bundle). The required R
packages are listed on the Extension Bundle Details dialog. R packages can be obtained from any of the
R CRAN mirror sites, which are accessed from http://www.r-project.org/. Be sure to obtain the
versions of the packages that match your R version. The version-specific packages are available from
links on the "Contributed Packages" page of the CRAN mirror site.

v For Windows Vista or later, you might be required to install IBM SPSS Statistics - Essentials for R from
an administrator account on your computer to enable use of the IBM SPSS Statistics - Integration
Plug-in for R.

Pushing an installation

As an alternative to the manual installation described above you can push the installation to Windows
computers. This is most useful for network administrators who need to install to multiple end users.
Following is the form of the command line for pushing an installation:
<installer_name> /S /v/qn

where <installer_name> is the name of the installer file for IBM SPSS Statistics - Essentials for R--for
example: SPSSStatisticsEssentialsForR_23000_Win64.exe .

Note: You must have administrator privileges to push an installation.

As part of the installation, any R packages required by the R examples will be automatically downloaded
over the Internet if possible. This may take a few minutes.

Before you start using the IBM SPSS Statistics - Integration Plug-in for
R
After you install IBM SPSS Statistics - Essentials for R, you will be able to start developing R applications
with the IBM SPSS Statistics - Integration Plug-in for R. Complete documentation for the plug-in is
available from the topic Integration Plug-in for R in the IBM SPSS Statistics Help system. You may also
want to go through the tutorials available from Help>Working with R.

2 IBM SPSS Statistics - Essentials for R: Installation Instructions for Windows

http://www.r-project.org/


Accessing the R examples

IBM SPSS Statistics - Essentials for R includes a set of working examples of R extensions for IBM SPSS
Statistics that provide capabilities beyond what is available with built-in SPSS Statistics procedures. All of
the R extensions include a custom dialog and an extension command. The extension commands can be
run from SPSS Statistics command syntax in the same manner as any built-in command such as
FREQUENCIES. You can generate command syntax for each extension command from the associated custom
dialog.

Table 1. Listing of R extensions.

Menu location Command name Description

Analyze>Reports>Apriori SPSSINC APRIORI Discover frequent itemsets, association rules
using the Apriori algorithm.

Analyze>Regression>Residual
Heteroscedasticity Test

SPSSINC BREUSCH PAGAN Estimate a linear model and perform a
heteroscedasticity test.

Analyze>Correlate>Heterogeneous
Correlations

SPSSINC HETCOR Calculate correlations between nominal,
ordinal, and scale variables.

Analyze>Descriptive
Statistics>Two-Variable or Group
Q-Q Plot

SPSSINC QQPLOT2 Two variable or two group Q-Q plot.

Analyze>Regression>Quantile
Regression

SPSSINC QUANTREG Estimate one or more conditional quantiles
for a linear model.

Analyze>RanFor Estimation SPSSINC RANFOR Estimate random forest.

Analyze>Ranfor Prediction SPSSINC RANPRED Compute predicted values for new data
using forests from SPSSINC RANFOR.

Analyze>Regression>Robust
Regression

SPSSINC ROBUST REGR Estimate a linear regression model by robust
regression, using an M estimator.

Analyze>Regression>Tobit
Regression

SPSSINC TOBIT REGR Estimate a regression model whose
dependent variable has a fixed lower bound,
upper bound, or both.

Graphs>Bagplot STATS BAGPLOT Create a bagplot or a matrix of bagplots.

Analyze>Survival>Cox Regression
Extension

STATS COXREGR Cox (proportional hazards) regression.

Analyze>Classify>Predict Using
Density Cluster

STATS DBPRED Prediction based on density-based clustering.

Analyze>Classify>Density-Based
Clustering

STATS DBSCAN Density-based clustering.

Transform>Disaggregate a Time
Series

STATS DISAGG Disaggregate a time series into a series at a
higher frequency.

Analyze>Descriptive
Statistics>Distribution Fit

STATS DISTFIT Fit probability distributions.

Analyze>Regression>Equation
Systems

STATS EQNSYSTEM Estimate system of linear equations.

Analyze>Scale>Extended Rasch STATS EXRASCH Calculate standard and extended Rasch
models.

Analyze>Regression>Firth Logistic
Regression

STATS FIRTHLOG Firth logistic regression.

Analyze>Forecasting>GARCH
Models

STATS GARCH GARCH models.

IBM SPSS Statistics - Essentials for R: Installation Instructions for Windows 3



Table 1. Listing of R extensions (continued).

Menu location Command name Description

Analyze>Generalized Linear
Models>Generalized Boosted
Regression

STATS GBM Estimate generalized boosted regression
models.

Analyze>Generalized Linear
Models>Generalized Boosted
Regression Prediction

STATS GBMPRED Calculate predictions for generalized boosted
regression models.

File>Get R Workspace STATS GET R Get information about R workspace contents
and create SPSS datasets.

Analyze>Scale>Graded Response
Model

STATS GRM Fit graded response models to ordinal data.

Analyze>Regression>Heckman
Regression

STATS HECKMAN REGR Estimate censored/truncated regression or
switching regression.

Analyze>Descriptive
Statistics>Inequality Measures

STATS INEQUALITY Various inequality measures for a variable
distribution.

Analyze>Scale>Item Response
Model

STATS IRM Fit three parameter item response models.

Analyze>Descriptive Statistics>Fit
Smoothed Distributions

STATS KERNEL DENSITY Fit kernel-smoothed distributions.

Analyze>Loglinear>Latent Class
Analysis

STATS LATENT CLASS Latent Class Analysis.

Analyze>Regression>LOESS Fit STATS LOESS Fit a loess curve to a model.

Analyze>Linear Programming STATS LP Solve linear and integer programming
problems.

Analyze>Descriptive
Statistics>Calculate Adjusted P
Values

STATS PADJUST Calculate p-values adjusted for multiple
testing.

Analyze>Generalized Linear
Models>Proportional Regression

STATS PROPOR REGR Linear models for dependent variables that
are proportions.

Analyze>Generalized Linear
Models>Proportional Regression
Prediction

STATS PROPOR REGRPRED Calculate predicted values for proportional
regression models.

Analyze>Regression>Regression
Discontinuity

STATS RDD Regression discontinuity analysis.

Analyze>Regression>Regression
Relative Importance

STATS RELIMP Relative importance measures for regression.

Analyze>Regression>Structural
Change Detection

STATS STRUC CHANGE Test for structural change in regression
models with ordered cases.

Analyze>Survival>Parametric
Regression

STATS SURVREG Parametric survival regression.

Analyze>Classify>Support Vector
Machines

STATS SVM Support vector machine.

Analyze>Generalized Linear
Models>Zero-Inflated Count
Models

STATS ZEROINFL Estimate and predict a zero-inflated count
model.

Important:
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The Heterogeneous Correlations extension requires both the IBM SPSS Statistics - Integration Plug-in for
R and the IBM SPSS Statistics - Integration Plug-in for Python. The IBM SPSS Statistics - Integration
Plug-in for Python is included with IBM SPSS Statistics - Essentials for Python, which is installed by
default with your IBM SPSS Statistics product.

Notes
v Help for each of the R extensions is available from the Help button on the associated dialog box. The

help is not, however, integrated with the SPSS Statistics Help system.
v Complete syntax help for each of the extension commands is available by positioning the cursor within

the command (in a syntax window) and pressing the F1 key. It is also available by running the
command and including the /HELP subcommand. For example:

SPSSINC HETCOR /HELP.

The command syntax help is not, however, integrated with the SPSS Statistics Help system and is not
included in the Command Syntax Reference.

Note: The F1 mechanism for displaying help is not supported in distributed mode.
v If the menu location that is specified for an extension command is not present in your IBM SPSS

Statistics product, then look on the Custom menu for the associated dialog.
v The dialogs were created with the Custom Dialog Builder in IBM SPSS Statistics. You can view the

design for any of the dialogs and you can customize them using the Custom Dialog Builder. It is
available from Utilities>Custom Dialogs>Custom Dialog Builder. To view the design for a dialog,
choose File>Open Installed from within the Custom Dialog Builder.

v The implementation code (R source code file) and XML specification files for each of the R extension
commands can be found in the location where extension commands are installed on your computer. To
view the location, run the SHOW EXTPATHS syntax command. The output displays a list of locations
under the heading "Locations for extension commands". The files are installed to the first writable
location in the list.

v You may need to set your SPSS Statistics locale to match the SPSS Statistics output language (OLANG) in
order to display extended characters properly, even when working in Unicode mode. For example, if
the output language is Japanese then you may need to set your SPSS Statistics locale to Japanese, as in
SET LOCALE=’japanese’.

v Other extension commands that are not included in IBM SPSS Statistics - Essentials for R are available
for download from the Download Extension Bundles dialog, accessible from Utilities>Extension
Bundles>Download and Install Extension Bundles. The Download Extension Bundles dialog also
displays any updates that are available for the extension commands included with IBM SPSS Statistics -
Essentials for R in addition to updates for any other extension bundles that you installed.

v If you are installing extension bundles on SPSS Statistics Server, you can use a script to install multiple
extension bundles at once. For information, see Core System > Utilities > Extension bundles >
Installing local extension bundles > Batch installation of extension bundles in the Help system.

Repairing an installation
If you uninstall and then reinstall the IBM SPSS Statistics 23 application or R 3.1, then please uninstall
and then reinstall version 23 of IBM SPSS Statistics - Essentials for R.

Uninstalling IBM SPSS Statistics - Essentials for R components
1. Uninstall IBM SPSS Statistics - Essentials for R 23 from the Windows Control Panel.
2. Uninstall R version 3.1 from the Windows Control Panel, if desired.
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